1 |
valya |
1.11 |
### RPM cms dbs-server DBS_1_0_1
|
2 |
eulisse |
1.1 |
|
3 |
|
|
%define cvstag %v
|
4 |
eulisse |
1.4 |
Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS/Servers/JavaServer&export=DBS&tag=-r%{cvstag}&output=/dbs-server.tar.gz
|
5 |
valya |
1.12 |
Requires: apache-ant mysql oracle apache-tomcat
|
6 |
|
|
#Requires: apache-ant mysql oracle apache-tomcat java-jdk
|
7 |
valya |
1.5 |
#Requires: apache-ant apache-tomcat
|
8 |
eulisse |
1.1 |
|
9 |
|
|
%prep
|
10 |
|
|
%setup -n DBS
|
11 |
|
|
%build
|
12 |
eulisse |
1.4 |
echo "PWD=$PWD"
|
13 |
|
|
cd Servers/JavaServer
|
14 |
|
|
echo "PWD=$PWD"
|
15 |
|
|
ant --noconfig dist
|
16 |
|
|
cd ../../
|
17 |
eulisse |
1.1 |
|
18 |
|
|
%install
|
19 |
valya |
1.7 |
mkdir -p %{i}/Servers/JavaServer/
|
20 |
|
|
cp -r Servers/JavaServer/* %{i}/Servers/JavaServer
|
21 |
eulisse |
1.1 |
|
22 |
valya |
1.8 |
# copy war file
|
23 |
|
|
cp %{i}/Servers/JavaServer/DBS.war $APACHE_TOMCAT_ROOT/webapps
|
24 |
|
|
|
25 |
|
|
mkdir -p %{i}/etc/profile.d
|
26 |
|
|
(echo "#!/bin/sh"; \
|
27 |
|
|
echo "source $ORACLE_ROOT/etc/profile.d/init.sh"; \
|
28 |
|
|
echo "source $MYSQL_ROOT/etc/profile.d/init.sh"; \
|
29 |
|
|
echo "source $APACHE_TOMCAT_ROOT/etc/profile.d/init.sh"; \
|
30 |
|
|
echo "source $APACHE_ANT_ROOT/etc/profile.d/init.sh"; \
|
31 |
|
|
echo "source $JAVA_JDK_ROOT/etc/profile.d/init.sh"; \
|
32 |
|
|
) > %{i}/etc/profile.d/dependencies-setup.sh
|
33 |
|
|
|
34 |
|
|
(echo "#!/bin/tcsh"; \
|
35 |
|
|
echo "source $ORACLE_ROOT/etc/profile.d/init.csh"; \
|
36 |
|
|
echo "source $MYSQL_ROOT/etc/profile.d/init.csh"; \
|
37 |
|
|
echo "source $APACHE_TOMCAT_ROOT/etc/profile.d/init.csh"; \
|
38 |
|
|
echo "source $APACHE_ANT_ROOT/etc/profile.d/init.csh"; \
|
39 |
|
|
echo "source $JAVA_JDK_ROOT/etc/profile.d/init.csh"; \
|
40 |
|
|
) > %{i}/etc/profile.d/dependencies-setup.csh
|
41 |
|
|
|
42 |
|
|
|
43 |
|
|
%post
|
44 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
45 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|
46 |
valya |
1.9 |
|