ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-web.spec
Revision: 1.112
Committed: Wed Jun 25 01:41:42 2008 UTC (16 years, 10 months ago) by valya
Branch: MAIN
CVS Tags: WEBTOOLS-APPS_20080624
Changes since 1.111: +1 -1 lines
Log Message:
New tag

File Contents

# User Rev Content
1 valya 1.112 ### RPM cms dbs-web V04_01_18
2 valya 1.26 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 eulisse 1.58 ## INITENV +PATH PYTHONPATH $ELEMENTTREE_ROOT/share/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
4     ## INITENV SET DDHOME $DBS_WEB_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
5     ## INITENV SET DBS_DBPARAM $DDHOME/DBParam
6 valya 1.61 ## INITENV SET PYTHONPATH ${DDHOME}:${DDHOME}/QueryBuilder:${PYTHONPATH}
7 eulisse 1.58
8 metson 1.73 %define cvstag %{realversion}
9     %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
10     Source: %cvsserver&strategy=checkout&module=DBS/Web/DataDiscovery&nocache=true&export=DBS&tag=-r%{cvstag}&output=/dbs-web.tar.gz
11 valya 1.81 Requires: python py2-sqlalchemy cherrypy py2-cheetah webtools yui elementtree dbs-client mysql py2-mysqldb sqlite py2-pysqlite py2-cx-oracle oracle-env
12 eulisse 1.1
13     %prep
14 valya 1.26 %setup -n DBS/Web/DataDiscovery
15 eulisse 1.1 %build
16    
17     %install
18 valya 1.3 mkdir -p %{i}/bin
19     mkdir -p %{i}/etc/profile.d
20 valya 1.108 mkdir -p %{i}/etc/init.d
21 valya 1.26 mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
22 metson 1.76 cp -r * %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
23 eulisse 1.1
24 valya 1.108 # copy init script
25     cp cmsweb_discovery dbs_discovery %{i}/etc/init.d
26     chmod a+x %{i}/etc/init.d/*
27    
28 valya 1.26 cd %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
29 valya 1.37 #ln -s $YUI_ROOT/build YUI
30 valya 1.3
31 eulisse 1.55
32     # This will generate the correct dependencies-setup.sh/dependencies-setup.csh
33     # using the information found in the Requires statements of the different
34     # specs and their dependencies.
35     echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh
36     echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh
37     echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
38     for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
39     do
40     case X$tool in
41     Xdistcc|Xccache )
42     ;;
43     * )
44     toolcap=`echo $tool | tr a-z- A-Z_`
45     eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh
46     eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh
47     ;;
48     esac
49     done
50     perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh
51     perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh
52    
53 valya 1.3 # Generate python code from templates
54     ./scripts/genTemplates.sh
55    
56     %post
57     %{relocateConfig}etc/profile.d/dependencies-setup.sh
58     %{relocateConfig}etc/profile.d/dependencies-setup.csh
59 valya 1.37
60     # setup approripate links and made post install procedure
61     . $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.sh
62     ln -s $YUI_ROOT/build $DDHOME/YUI
63 valya 1.59 ln -s $YUI_ROOT $DDHOME/yui
64     mkdir -p $DDHOME/rss
65 valya 1.37 ln -s $WEBTOOLS_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/Controllers $DDHOME/WEBTOOLS
66 valya 1.97 pdir=$RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
67 valya 1.95 if [ `hostname` == "cmswttest.cern.ch" ]; then
68 valya 1.97 ${pdir}/scripts/post-install.sh https://cmsweb.cern.ch/dbs_discovery_wttest 8008
69     cat ${pdir}/DBSDD.conf | sed "s/# URL=/URL=/g" | sed "s/# PORT=/PORT=/g" > ${pdir}/DBSDD.conf.tmp
70     mv ${pdir}/DBSDD.conf.tmp ${pdir}/DBSDD.conf
71     else
72     ${pdir}/scripts/post-install.sh `hostname` 8003
73     cat ${pdir}/DBSDD.conf | sed "s/# URL=/### _url_=/g" | sed "s/# PORT=/### _port_=/g" > ${pdir}/DBSDD.conf.tmp
74     mv ${pdir}/DBSDD.conf.tmp ${pdir}/DBSDD.conf
75 valya 1.79 fi
76     if [ -n "${WEBTOOLS_CONF}" ] && [ -f ${WEBTOOLS_CONF}/dbs/DBParam ]; then
77 valya 1.97 rm -f ${pdir}/DBParam
78     ln -s ${WEBTOOLS_CONF}/dbs/DBParam ${pdir}/DBParam
79 valya 1.78 fi
80 valya 1.95 ###export TARGET_PROJECT=dbs-web