ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-web.spec
Revision: 1.28
Committed: Wed May 23 14:10:53 2007 UTC (17 years, 11 months ago) by valya
Branch: MAIN
Changes since 1.27: +1 -1 lines
Log Message:
New tag

File Contents

# User Rev Content
1 valya 1.28 ### RPM cms dbs-web V03_04_19
2 valya 1.26 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 eulisse 1.1
4     %define cvstag %v
5 valya 1.26 #Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS/Web/DataDiscovery&export=DBS/Web/DataDiscovery&tag=-r%{cvstag}&output=/dbs-web.tar.gz
6     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS/Web/DataDiscovery&tag=-r%{cvstag}&output=/dbs-web.tar.gz
7 valya 1.23 Requires: python dls py2-sqlalchemy cherrypy mysql py2-mysqldb oracle py2-cx-oracle sqlite py2-pysqlite py2-cheetah webtools yui elementtree
8 eulisse 1.1
9     %prep
10 valya 1.26 %setup -n DBS/Web/DataDiscovery
11 eulisse 1.1 %build
12    
13     %install
14 valya 1.3 mkdir -p %{i}/bin
15     mkdir -p %{i}/etc/profile.d
16 valya 1.26 mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
17     cp -r Web/DataDiscovery/* %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
18 eulisse 1.1
19 valya 1.26 cd %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
20 valya 1.8 ln -s $YUI_ROOT/build YUI
21 valya 1.26 #ln -s $WEBTOOLS_ROOT/lib/python2.4/site-packages/Controllers/Common Common
22     #ln -s $WEBTOOLS_ROOT/lib/python2.4/site-packages/Controllers/SecurityModule SecurityModule
23    
24 valya 1.3
25     # here I use octal code \044 for $ sign since I want "$NAME" to be appear in
26     # init.sh file, instead of interpreting it here.
27     (echo "#!/bin/sh"; \
28     echo "source $PYTHON_ROOT/etc/profile.d/init.sh"; \
29     echo "source $CHERRYPY_ROOT/etc/profile.d/init.sh"; \
30     echo "source $PY2_CHEETAH_ROOT/etc/profile.d/init.sh"; \
31     echo "source $PY2_SQLALCHEMY_ROOT/etc/profile.d/init.sh"; \
32 valya 1.5 echo "source $PY2_PYSQLITE_ROOT/etc/profile.d/init.sh"; \
33 valya 1.3 echo "source $WEBTOOLS_ROOT/etc/profile.d/init.sh"; \
34     echo "source $YUI_ROOT/etc/profile.d/init.sh"; \
35     echo "source $ORACLE_ROOT/etc/profile.d/init.sh"; \
36     echo "source $PY2_CX_ORACLE_ROOT/etc/profile.d/init.sh"; \
37     echo "source $MYSQL_ROOT/etc/profile.d/init.sh"; \
38     echo "source $DLS_ROOT/etc/profile.d/init.sh"; \
39 valya 1.5 echo -e "export DLSHOME=$DLS_ROOT/Client/lib"; \
40 valya 1.3 echo -e "export DDHOME=\044DBS_WEB_ROOT/lib/Web/DataDiscovery/"; \
41     echo -e "export TNS_ADMIN=\044DBS_WEB_ROOT/lib/Web/DataDiscovery/"; \
42     echo -e "export DBS_DBPARAM=\044DBS_WEB_ROOT/lib/Web/DataDiscovery/DBParam"; \
43 valya 1.5 echo -e "export PYTHONPATH=\044PYTHONPATH:\044DLSHOME"; \
44     echo -e "export PYTHONPATH=\044DDHOME:\044DDHOME/QueryBuilder:\044PYTHONPATH"; \
45 valya 1.16 echo -e "rm -f \044DDHOME/YUI"; \
46     echo -e "ln -s $YUI_ROOT/build \044DDHOME/YUI"; \
47 valya 1.3 ) > %{i}/etc/profile.d/dependencies-setup.sh
48    
49     (echo "#!/bin/tcsh"; \
50     echo "source $PYTHON_ROOT/etc/profile.d/init.csh"; \
51     echo "source $CHERRYPY_ROOT/etc/profile.d/init.csh"; \
52     echo "source $PY2_CHEETAH_ROOT/etc/profile.d/init.csh"; \
53     echo "source $PY2_SQLALCHEMY_ROOT/etc/profile.d/init.csh"; \
54 valya 1.5 echo "source $PY2_PYSQLITE_ROOT/etc/profile.d/init.csh"; \
55 valya 1.3 echo "source $WEBTOOLS_ROOT/etc/profile.d/init.csh"; \
56     echo "source $YUI_ROOT/etc/profile.d/init.csh"; \
57     echo "source $ORACLE_ROOT/etc/profile.d/init.csh"; \
58     echo "source $PY2_CX_ORACLE_ROOT/etc/profile.d/init.csh"; \
59     echo "source $MYSQL_ROOT/etc/profile.d/init.csh"; \
60     echo "source $DLS_ROOT/etc/profile.d/init.csh"; \
61 valya 1.5 echo -e "setenv DLSHOME $DLS_ROOT/Client/lib"; \
62 valya 1.3 echo -e "setenv DDHOME \044DBS_WEB_ROOT/lib/Web/DataDiscovery/"; \
63     echo -e "setenv TNS_ADMIN \044DBS_WEB_ROOT/lib/Web/DataDiscovery/"; \
64     echo -e "setenv DBS_DBPARAM \044DBS_WEB_ROOT/lib/Web/DataDiscovery/DBParam"; \
65 valya 1.5 echo -e "setenv PYTHONPATH \044PYTHONPATH:\044DLSHOME"; \
66     echo -e "setenv PYTHONPATH \044DDHOME:\044DDHOME/QueryBuilder:\044PYTHONPATH"; \
67 valya 1.16 echo -e "rm -f \044DDHOME/YUI"; \
68     echo -e "ln -s $YUI_ROOT/build \044DDHOME/YUI"; \
69 valya 1.3 ) > %{i}/etc/profile.d/dependencies-setup.csh
70    
71     # Generate python code from templates
72     ./scripts/genTemplates.sh
73    
74     %post
75     %{relocateConfig}etc/profile.d/dependencies-setup.sh
76     %{relocateConfig}etc/profile.d/dependencies-setup.csh