ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-web.spec
Revision: 1.34
Committed: Mon Jul 9 20:24:04 2007 UTC (17 years, 9 months ago) by valya
Branch: MAIN
Changes since 1.33: +3 -1 lines
Log Message:
New tag and add python path to include elementtree

File Contents

# User Rev Content
1 valya 1.34 ### RPM cms dbs-web V03_04_25
2 valya 1.26 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 eulisse 1.1
4     %define cvstag %v
5 valya 1.26 #Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS/Web/DataDiscovery&export=DBS/Web/DataDiscovery&tag=-r%{cvstag}&output=/dbs-web.tar.gz
6     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS/Web/DataDiscovery&tag=-r%{cvstag}&output=/dbs-web.tar.gz
7 valya 1.23 Requires: python dls py2-sqlalchemy cherrypy mysql py2-mysqldb oracle py2-cx-oracle sqlite py2-pysqlite py2-cheetah webtools yui elementtree
8 eulisse 1.1
9     %prep
10 valya 1.26 %setup -n DBS/Web/DataDiscovery
11 eulisse 1.1 %build
12    
13     %install
14 valya 1.3 mkdir -p %{i}/bin
15     mkdir -p %{i}/etc/profile.d
16 valya 1.26 mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
17     cp -r Web/DataDiscovery/* %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
18 eulisse 1.1
19 valya 1.26 cd %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
20 valya 1.8 ln -s $YUI_ROOT/build YUI
21 valya 1.26 #ln -s $WEBTOOLS_ROOT/lib/python2.4/site-packages/Controllers/Common Common
22     #ln -s $WEBTOOLS_ROOT/lib/python2.4/site-packages/Controllers/SecurityModule SecurityModule
23    
24 valya 1.3
25     # here I use octal code \044 for $ sign since I want "$NAME" to be appear in
26     # init.sh file, instead of interpreting it here.
27     (echo "#!/bin/sh"; \
28     echo "source $PYTHON_ROOT/etc/profile.d/init.sh"; \
29     echo "source $CHERRYPY_ROOT/etc/profile.d/init.sh"; \
30     echo "source $PY2_CHEETAH_ROOT/etc/profile.d/init.sh"; \
31     echo "source $PY2_SQLALCHEMY_ROOT/etc/profile.d/init.sh"; \
32 valya 1.5 echo "source $PY2_PYSQLITE_ROOT/etc/profile.d/init.sh"; \
33 valya 1.3 echo "source $WEBTOOLS_ROOT/etc/profile.d/init.sh"; \
34     echo "source $YUI_ROOT/etc/profile.d/init.sh"; \
35     echo "source $ORACLE_ROOT/etc/profile.d/init.sh"; \
36     echo "source $PY2_CX_ORACLE_ROOT/etc/profile.d/init.sh"; \
37     echo "source $MYSQL_ROOT/etc/profile.d/init.sh"; \
38     echo "source $DLS_ROOT/etc/profile.d/init.sh"; \
39 valya 1.29 echo "source $ELEMENTTREE_ROOT/etc/profile.d/init.sh"; \
40 valya 1.34 echo -e "export PYTHONPATH=$PYTHONPATH:$ELEMENTTREE_ROOT/share/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/"; \
41 valya 1.5 echo -e "export DLSHOME=$DLS_ROOT/Client/lib"; \
42 valya 1.29 echo -e "export DDHOME=\044DBS_WEB_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages"; \
43     echo -e "export TNS_ADMIN=\044DDHOME"; \
44     echo -e "export DBS_DBPARAM=\044DDHOME/DBParam"; \
45 valya 1.5 echo -e "export PYTHONPATH=\044PYTHONPATH:\044DLSHOME"; \
46     echo -e "export PYTHONPATH=\044DDHOME:\044DDHOME/QueryBuilder:\044PYTHONPATH"; \
47 valya 1.16 echo -e "rm -f \044DDHOME/YUI"; \
48     echo -e "ln -s $YUI_ROOT/build \044DDHOME/YUI"; \
49 valya 1.3 ) > %{i}/etc/profile.d/dependencies-setup.sh
50    
51     (echo "#!/bin/tcsh"; \
52     echo "source $PYTHON_ROOT/etc/profile.d/init.csh"; \
53     echo "source $CHERRYPY_ROOT/etc/profile.d/init.csh"; \
54     echo "source $PY2_CHEETAH_ROOT/etc/profile.d/init.csh"; \
55     echo "source $PY2_SQLALCHEMY_ROOT/etc/profile.d/init.csh"; \
56 valya 1.5 echo "source $PY2_PYSQLITE_ROOT/etc/profile.d/init.csh"; \
57 valya 1.3 echo "source $WEBTOOLS_ROOT/etc/profile.d/init.csh"; \
58     echo "source $YUI_ROOT/etc/profile.d/init.csh"; \
59     echo "source $ORACLE_ROOT/etc/profile.d/init.csh"; \
60     echo "source $PY2_CX_ORACLE_ROOT/etc/profile.d/init.csh"; \
61     echo "source $MYSQL_ROOT/etc/profile.d/init.csh"; \
62     echo "source $DLS_ROOT/etc/profile.d/init.csh"; \
63 valya 1.29 echo "source $ELEMENTTREE_ROOT/etc/profile.d/init.csh"; \
64 valya 1.34 echo -e "setup PYTHONPATH $PYTHONPATH:$ELEMENTTREE_ROOT/share/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/"; \
65 valya 1.5 echo -e "setenv DLSHOME $DLS_ROOT/Client/lib"; \
66 valya 1.29 echo -e "setenv DDHOME \044DBS_WEB_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages"; \
67     echo -e "setenv TNS_ADMIN \044DDHOME"; \
68     echo -e "setenv DBS_DBPARAM \044DDHOME/DBParam"; \
69 valya 1.5 echo -e "setenv PYTHONPATH \044PYTHONPATH:\044DLSHOME"; \
70     echo -e "setenv PYTHONPATH \044DDHOME:\044DDHOME/QueryBuilder:\044PYTHONPATH"; \
71 valya 1.16 echo -e "rm -f \044DDHOME/YUI"; \
72     echo -e "ln -s $YUI_ROOT/build \044DDHOME/YUI"; \
73 valya 1.3 ) > %{i}/etc/profile.d/dependencies-setup.csh
74    
75     # Generate python code from templates
76     ./scripts/genTemplates.sh
77    
78     %post
79     %{relocateConfig}etc/profile.d/dependencies-setup.sh
80     %{relocateConfig}etc/profile.d/dependencies-setup.csh