ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-web.spec
Revision: 1.80
Committed: Sat Mar 22 01:42:44 2008 UTC (17 years, 1 month ago) by valya
Branch: MAIN
CVS Tags: WEBTOOLS-APPS_20080326_2, WEBTOOLS-APPS_20080326, DBSweb_260308_1, DBSweb_260308
Changes since 1.79: +1 -1 lines
Log Message:
New tag

File Contents

# User Rev Content
1 valya 1.80 ### RPM cms dbs-web V04_00_03
2 valya 1.26 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 eulisse 1.58 ## INITENV +PATH PYTHONPATH $ELEMENTTREE_ROOT/share/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
4     ## INITENV SET DDHOME $DBS_WEB_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
5     ## INITENV SET TNS_ADMIN $DDHOME
6     ## INITENV SET DBS_DBPARAM $DDHOME/DBParam
7 valya 1.61 ## INITENV SET PYTHONPATH ${DDHOME}:${DDHOME}/QueryBuilder:${PYTHONPATH}
8 eulisse 1.58
9 metson 1.73 %define cvstag %{realversion}
10     %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
11     Source: %cvsserver&strategy=checkout&module=DBS/Web/DataDiscovery&nocache=true&export=DBS&tag=-r%{cvstag}&output=/dbs-web.tar.gz
12 valya 1.69 Requires: python py2-sqlalchemy cherrypy py2-cheetah webtools yui elementtree dbs-client mysql py2-mysqldb sqlite py2-pysqlite py2-cx-oracle
13 eulisse 1.1
14     %prep
15 valya 1.26 %setup -n DBS/Web/DataDiscovery
16 eulisse 1.1 %build
17    
18     %install
19 valya 1.3 mkdir -p %{i}/bin
20     mkdir -p %{i}/etc/profile.d
21 valya 1.26 mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
22 metson 1.76 cp -r * %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
23 eulisse 1.1
24 valya 1.26 cd %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
25 valya 1.37 #ln -s $YUI_ROOT/build YUI
26 valya 1.3
27 eulisse 1.55
28     # This will generate the correct dependencies-setup.sh/dependencies-setup.csh
29     # using the information found in the Requires statements of the different
30     # specs and their dependencies.
31     echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh
32     echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh
33     echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
34     for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
35     do
36     case X$tool in
37     Xdistcc|Xccache )
38     ;;
39     * )
40     toolcap=`echo $tool | tr a-z- A-Z_`
41     eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh
42     eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh
43     ;;
44     esac
45     done
46     perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh
47     perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh
48    
49 valya 1.3 # Generate python code from templates
50     ./scripts/genTemplates.sh
51    
52     %post
53     %{relocateConfig}etc/profile.d/dependencies-setup.sh
54     %{relocateConfig}etc/profile.d/dependencies-setup.csh
55 valya 1.37
56     # setup approripate links and made post install procedure
57     . $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.sh
58     ln -s $YUI_ROOT/build $DDHOME/YUI
59 valya 1.59 ln -s $YUI_ROOT $DDHOME/yui
60     mkdir -p $DDHOME/rss
61 valya 1.37 ln -s $WEBTOOLS_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/Controllers $DDHOME/WEBTOOLS
62 valya 1.78 if [ `hostname`=="cmswttest.cern.ch" ]; then
63     $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/scripts/post-install.sh https://cmsweb.cern.ch/dbs_discovery_wttest 8008
64     cat $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf | sed "s/# URL=/URL=/g" | sed "s/# PORT=/PORT=/g" > $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf.tmp
65     mv $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf.tmp $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf
66     rm -f $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBParam
67 valya 1.79 if [ -n "${WEBTOOLS_CONF}" ] && [ -f ${WEBTOOLS_CONF}/dbs/DBParam ]; then
68     ln -s ${WEBTOOLS_CONF}/dbs/DBParam $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBParam
69     fi
70 valya 1.78 else
71     $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/scripts/post-install.sh `hostname` 8003
72 valya 1.79 if [ -n "${WEBTOOLS_CONF}" ] && [ -f ${WEBTOOLS_CONF}/dbs/DBParam ]; then
73     ln -s ${WEBTOOLS_CONF}/dbs/DBParam $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBParam
74     fi
75 valya 1.78 fi