ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs-web.spec
Revision: 1.92
Committed: Wed Apr 9 19:23:33 2008 UTC (17 years ago) by valya
Branch: MAIN
CVS Tags: WEBTOOLS-APPS_20080409_1
Changes since 1.91: +1 -1 lines
Log Message:
New tag

File Contents

# User Rev Content
1 valya 1.92 ### RPM cms dbs-web V04_01_01
2 valya 1.26 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 eulisse 1.58 ## INITENV +PATH PYTHONPATH $ELEMENTTREE_ROOT/share/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
4     ## INITENV SET DDHOME $DBS_WEB_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
5     ## INITENV SET DBS_DBPARAM $DDHOME/DBParam
6 valya 1.61 ## INITENV SET PYTHONPATH ${DDHOME}:${DDHOME}/QueryBuilder:${PYTHONPATH}
7 eulisse 1.58
8 metson 1.73 %define cvstag %{realversion}
9     %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
10     Source: %cvsserver&strategy=checkout&module=DBS/Web/DataDiscovery&nocache=true&export=DBS&tag=-r%{cvstag}&output=/dbs-web.tar.gz
11 valya 1.81 Requires: python py2-sqlalchemy cherrypy py2-cheetah webtools yui elementtree dbs-client mysql py2-mysqldb sqlite py2-pysqlite py2-cx-oracle oracle-env
12 eulisse 1.1
13     %prep
14 valya 1.26 %setup -n DBS/Web/DataDiscovery
15 eulisse 1.1 %build
16    
17     %install
18 valya 1.3 mkdir -p %{i}/bin
19     mkdir -p %{i}/etc/profile.d
20 valya 1.26 mkdir -p %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
21 metson 1.76 cp -r * %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
22 eulisse 1.1
23 valya 1.26 cd %i/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages
24 valya 1.37 #ln -s $YUI_ROOT/build YUI
25 valya 1.3
26 eulisse 1.55
27     # This will generate the correct dependencies-setup.sh/dependencies-setup.csh
28     # using the information found in the Requires statements of the different
29     # specs and their dependencies.
30     echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh
31     echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh
32     echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
33     for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
34     do
35     case X$tool in
36     Xdistcc|Xccache )
37     ;;
38     * )
39     toolcap=`echo $tool | tr a-z- A-Z_`
40     eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh
41     eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh
42     ;;
43     esac
44     done
45     perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh
46     perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh
47    
48 valya 1.3 # Generate python code from templates
49     ./scripts/genTemplates.sh
50    
51     %post
52     %{relocateConfig}etc/profile.d/dependencies-setup.sh
53     %{relocateConfig}etc/profile.d/dependencies-setup.csh
54 valya 1.37
55     # setup approripate links and made post install procedure
56     . $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.sh
57     ln -s $YUI_ROOT/build $DDHOME/YUI
58 valya 1.59 ln -s $YUI_ROOT $DDHOME/yui
59     mkdir -p $DDHOME/rss
60 valya 1.37 ln -s $WEBTOOLS_ROOT/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/Controllers $DDHOME/WEBTOOLS
61 valya 1.78 if [ `hostname`=="cmswttest.cern.ch" ]; then
62     $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/scripts/post-install.sh https://cmsweb.cern.ch/dbs_discovery_wttest 8008
63     cat $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf | sed "s/# URL=/URL=/g" | sed "s/# PORT=/PORT=/g" > $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf.tmp
64     mv $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf.tmp $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBSDD.conf
65     rm -f $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBParam
66 valya 1.79 if [ -n "${WEBTOOLS_CONF}" ] && [ -f ${WEBTOOLS_CONF}/dbs/DBParam ]; then
67     ln -s ${WEBTOOLS_CONF}/dbs/DBParam $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBParam
68     fi
69 valya 1.78 else
70     $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/scripts/post-install.sh `hostname` 8003
71 valya 1.79 if [ -n "${WEBTOOLS_CONF}" ] && [ -f ${WEBTOOLS_CONF}/dbs/DBParam ]; then
72     ln -s ${WEBTOOLS_CONF}/dbs/DBParam $RPM_INSTALL_PREFIX/%{pkgrel}/lib/python`echo $PYTHON_VERSION | cut -d. -f1,2`/site-packages/DBParam
73     fi
74 valya 1.78 fi