ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs.spec
Revision: 1.2
Committed: Mon Apr 3 15:43:16 2006 UTC (19 years ago) by eulisse
Branch: MAIN
Changes since 1.1: +2 -1 lines
Log Message:
Adds correct PYTHONPATH to the init.sh.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM cms dbs 0.1
2 eulisse 1.2 ## INITENV +PATH PYTHONPATH %i/lib/python
3 eulisse 1.1 %define cvstag HEAD
4     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=DBS&export=DBS&&tag=-r%{cvstag}&output=/DBS.tar.gz
5     Requires: python swig gsoap log4cplus
6    
7     %prep
8     %setup -n DBS
9     %build
10     (cd Servers/AppServer; make DBSHOME=%_builddir/DBS/Servers/AppServer PYTHONINCLUDE=$PYTHON_ROOT/include GSOAPHOME=$GSOAP_ROOT LOG4CXX=$LOG4CPLUS_ROOT SWIG_HOME=$SWIG_ROOT)
11     (cd Clients/CppAPI; make DBSHOME=%_builddir/DBS/Servers/AppServer GSOAPHOME=$GSOAP_ROOT)
12    
13     %install
14     mkdir -p %i/bin
15     mkdir -p %i/lib/python
16 eulisse 1.2 cp -r Clients/PythonAPI/* %i/lib/python
17 eulisse 1.1 cp Clients/CppAPI/client.exe %i/bin/dbsClient