ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs3.spec
Revision: 1.33
Committed: Fri Jan 20 13:07:26 2012 UTC (13 years, 3 months ago) by giffels
Branch: MAIN
CVS Tags: TW20120319k, TW20120319j, TW20120319i, TW20120319h, TW20120319g, TW20120319f, TW20120319e, TW20120319d, TW20120319c, TW20120319b, TW20120319a, TW20120309h, TW20120309g, TW20120309f, TW20120309e, TW20120309d, TW20120309c, TW20120309b, TW20120309a, HG1201d, HG1203a, HG1201c, HG1201b
Changes since 1.32: +2 -2 lines
Log Message:
New DBS3 tag 3.0.14b

File Contents

# User Rev Content
1 giffels 1.33 ### RPM cms dbs3 3.0.14b
2 lat 1.26 ## INITENV +PATH PYTHONPATH %i/$PYTHON_LIB_SITE_PACKAGES
3 giffels 1.28 ## INITENV +PATH PYTHONPATH %i/x$PYTHON_LIB_SITE_PACKAGES
4 giffels 1.25 ## INITENV SET DBS3_SERVER_ROOT %i/
5 giffels 1.30 %define webdoc_files %i/doc/
6 giffels 1.33 %define wmcver 0.8.22
7 giffels 1.15 %define cvstag %(echo %{realversion} | sed 's/[.]/_/g; s/^/DBS_/')
8 lat 1.18 %define svnserver svn://svn.cern.ch/reps/CMSDMWM
9     Source0: %svnserver/WMCore/tags/%{wmcver}?scheme=svn+ssh&strategy=export&module=WMCore&output=/wmcore_dbs.tar.gz
10     Source1: %svnserver/DBS/tags/%cvstag?scheme=svn+ssh&strategy=export&module=DBS3&output=/%{n}.tar.gz
11     Requires: python py2-simplejson py2-sqlalchemy py2-httplib2 cherrypy py2-cheetah yui
12 giffels 1.30 Requires: py2-cjson py2-mysqldb py2-cx-oracle py2-sphinx rotatelogs
13 diego 1.1
14     %prep
15 lat 1.18 %setup -T -b 0 -n WMCore
16     %setup -D -T -b 1 -n DBS3
17 diego 1.1
18     %build
19 lat 1.18 cd ../WMCore
20     python setup.py build_system -s wmc-web
21 giffels 1.25 cd ../DBS3
22     python setup.py build_system -s Server
23 diego 1.1
24     %install
25 lat 1.18 cd ../WMCore
26     python setup.py install_system -s wmc-web --prefix=%i
27     cd ../DBS3
28 giffels 1.25 python setup.py install_system -s Server --prefix=%i
29 lat 1.18 find %i -name '*.egg-info' -exec rm {} \;
30 diego 1.1
31 lat 1.18 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
32 diego 1.1 mkdir -p %i/etc/profile.d
33 lat 1.18 : > %i/etc/profile.d/dependencies-setup.sh
34     : > %i/etc/profile.d/dependencies-setup.csh
35     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
36     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
37     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
38     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
39     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
40     fi
41 diego 1.1 done
42    
43     %post
44 diego 1.14 %{relocateConfig}etc/profile.d/dependencies-setup.*sh
45 giffels 1.30
46     %files
47     %i/
48     %exclude %i/doc
49     ## SUBPACKAGE webdoc