ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs3.spec
Revision: 1.35
Committed: Fri Mar 16 16:45:06 2012 UTC (13 years, 1 month ago) by giffels
Branch: MAIN
CVS Tags: bld_1334854417_PHEDEX-combined-agents_slc5_amd64_gcc461, bld_1334681121_PHEDEX-combined-agents_slc5_amd64_gcc461, HG1204h, HG1204g, HG1204f, HG1204e, HG1204d, dieHG1204d
Changes since 1.34: +1 -1 lines
Log Message:
New DBS3 Tag 3.0.16

File Contents

# User Rev Content
1 giffels 1.35 ### RPM cms dbs3 3.0.16
2 lat 1.26 ## INITENV +PATH PYTHONPATH %i/$PYTHON_LIB_SITE_PACKAGES
3 giffels 1.28 ## INITENV +PATH PYTHONPATH %i/x$PYTHON_LIB_SITE_PACKAGES
4 giffels 1.25 ## INITENV SET DBS3_SERVER_ROOT %i/
5 giffels 1.30 %define webdoc_files %i/doc/
6 giffels 1.33 %define wmcver 0.8.22
7 giffels 1.15 %define cvstag %(echo %{realversion} | sed 's/[.]/_/g; s/^/DBS_/')
8 lat 1.18 %define svnserver svn://svn.cern.ch/reps/CMSDMWM
9     Source0: %svnserver/WMCore/tags/%{wmcver}?scheme=svn+ssh&strategy=export&module=WMCore&output=/wmcore_dbs.tar.gz
10     Source1: %svnserver/DBS/tags/%cvstag?scheme=svn+ssh&strategy=export&module=DBS3&output=/%{n}.tar.gz
11     Requires: python py2-simplejson py2-sqlalchemy py2-httplib2 cherrypy py2-cheetah yui
12 giffels 1.30 Requires: py2-cjson py2-mysqldb py2-cx-oracle py2-sphinx rotatelogs
13 diego 1.1
14     %prep
15 lat 1.18 %setup -T -b 0 -n WMCore
16     %setup -D -T -b 1 -n DBS3
17 diego 1.1
18     %build
19 lat 1.18 cd ../WMCore
20     python setup.py build_system -s wmc-web
21 giffels 1.25 cd ../DBS3
22     python setup.py build_system -s Server
23 diego 1.1
24     %install
25 giffels 1.34 mkdir -p %i/etc/profile.d %i/{x,}{bin,lib,data,doc} %i/{x,}$PYTHON_LIB_SITE_PACKAGES
26 lat 1.18 cd ../WMCore
27     python setup.py install_system -s wmc-web --prefix=%i
28     cd ../DBS3
29 giffels 1.25 python setup.py install_system -s Server --prefix=%i
30 lat 1.18 find %i -name '*.egg-info' -exec rm {} \;
31 diego 1.1
32 lat 1.18 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
33 diego 1.1 mkdir -p %i/etc/profile.d
34 lat 1.18 : > %i/etc/profile.d/dependencies-setup.sh
35     : > %i/etc/profile.d/dependencies-setup.csh
36     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
37     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
38     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
39     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
40     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
41     fi
42 diego 1.1 done
43    
44     %post
45 diego 1.14 %{relocateConfig}etc/profile.d/dependencies-setup.*sh
46 giffels 1.30
47     %files
48     %i/
49     %exclude %i/doc
50     ## SUBPACKAGE webdoc