1 |
giffels |
1.44 |
### RPM cms dbs3 3.1.0b
|
2 |
lat |
1.26 |
## INITENV +PATH PYTHONPATH %i/$PYTHON_LIB_SITE_PACKAGES
|
3 |
giffels |
1.28 |
## INITENV +PATH PYTHONPATH %i/x$PYTHON_LIB_SITE_PACKAGES
|
4 |
giffels |
1.25 |
## INITENV SET DBS3_SERVER_ROOT %i/
|
5 |
diego |
1.36 |
%define webdoc_files %{installroot}/%{pkgrel}/doc/
|
6 |
giffels |
1.43 |
%define wmcver 0.9.30
|
7 |
giffels |
1.15 |
%define cvstag %(echo %{realversion} | sed 's/[.]/_/g; s/^/DBS_/')
|
8 |
lat |
1.18 |
%define svnserver svn://svn.cern.ch/reps/CMSDMWM
|
9 |
giffels |
1.42 |
%define gitserver https://nodeload.github.com
|
10 |
giffels |
1.43 |
Source0: git://github.com/dmwm/WMCore.git?obj=master/%{wmcver}&export=WMCore&output=/WMCore4%{n}.tar.gz
|
11 |
|
|
Source1: %svnserver/DBS/tags/%cvstag?scheme=svn+ssh&strategy=export&module=DBS&output=/%{n}.tar.gz
|
12 |
giffels |
1.42 |
|
13 |
lat |
1.18 |
Requires: python py2-simplejson py2-sqlalchemy py2-httplib2 cherrypy py2-cheetah yui
|
14 |
giffels |
1.43 |
Requires: py2-cjson py2-mysqldb py2-cx-oracle dbs3-pycurl-client rotatelogs
|
15 |
lat |
1.41 |
BuildRequires: py2-sphinx
|
16 |
diego |
1.1 |
|
17 |
|
|
%prep
|
18 |
giffels |
1.43 |
%setup -T -b 0 -n WMCore
|
19 |
|
|
%setup -D -T -b 1 -n DBS
|
20 |
diego |
1.1 |
|
21 |
|
|
%build
|
22 |
giffels |
1.43 |
cd ../WMCore
|
23 |
lat |
1.18 |
python setup.py build_system -s wmc-web
|
24 |
giffels |
1.43 |
cd ../DBS
|
25 |
|
|
python setup.py build_system -s dbs-web
|
26 |
diego |
1.1 |
%install
|
27 |
giffels |
1.34 |
mkdir -p %i/etc/profile.d %i/{x,}{bin,lib,data,doc} %i/{x,}$PYTHON_LIB_SITE_PACKAGES
|
28 |
giffels |
1.43 |
cd ../WMCore
|
29 |
lat |
1.18 |
python setup.py install_system -s wmc-web --prefix=%i
|
30 |
giffels |
1.43 |
cd ../DBS
|
31 |
|
|
python setup.py install_system -s dbs-web --prefix=%i
|
32 |
lat |
1.18 |
find %i -name '*.egg-info' -exec rm {} \;
|
33 |
diego |
1.1 |
|
34 |
lat |
1.18 |
# Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
|
35 |
diego |
1.1 |
mkdir -p %i/etc/profile.d
|
36 |
lat |
1.18 |
: > %i/etc/profile.d/dependencies-setup.sh
|
37 |
|
|
: > %i/etc/profile.d/dependencies-setup.csh
|
38 |
|
|
for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
|
39 |
|
|
root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
|
40 |
|
|
if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
|
41 |
|
|
echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
42 |
|
|
echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
43 |
|
|
fi
|
44 |
diego |
1.1 |
done
|
45 |
|
|
|
46 |
|
|
%post
|
47 |
diego |
1.14 |
%{relocateConfig}etc/profile.d/dependencies-setup.*sh
|
48 |
giffels |
1.30 |
|
49 |
|
|
%files
|
50 |
diego |
1.36 |
%{installroot}/%{pkgrel}/
|
51 |
|
|
%exclude %{installroot}/%{pkgrel}/doc
|
52 |
giffels |
1.30 |
## SUBPACKAGE webdoc
|