ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dbs3.spec
Revision: 1.18
Committed: Fri Mar 18 15:17:42 2011 UTC (14 years, 1 month ago) by lat
Branch: MAIN
CVS Tags: TW20110407a, TW20110331c, TW20110331b, TW20110331a, TW20110330a, TW20110328a, TW20110322e, TW20110322d, TW20110322c, builder_2011-03-21_16-11-33_calendar-shift, builder_2011-03-21_16-08-10_calendar-shift, builder_2011-03-21_15-53-32_calendar-shift, builder_2011-03-18_17-21-58_cmsweb, HG1104a
Changes since 1.17: +23 -25 lines
Log Message:
Update to wmc-web 0.7.1a, build necessary part in this RPM.
Harmonise package structure with other server projects.

File Contents

# User Rev Content
1 giffels 1.17 ### RPM cms dbs3 3.0.6
2 diego 1.1 ## INITENV +PATH PYTHONPATH %i/Server/Python/src
3     ## INITENV SET DBS3_SERVER_ROOT %i/Server/Python
4 lat 1.18 %define wmcver WMCORE_0_7_1a
5 giffels 1.15 %define cvstag %(echo %{realversion} | sed 's/[.]/_/g; s/^/DBS_/')
6 lat 1.18 %define svnserver svn://svn.cern.ch/reps/CMSDMWM
7     Source0: %svnserver/WMCore/tags/%{wmcver}?scheme=svn+ssh&strategy=export&module=WMCore&output=/wmcore_dbs.tar.gz
8     Source1: %svnserver/DBS/tags/%cvstag?scheme=svn+ssh&strategy=export&module=DBS3&output=/%{n}.tar.gz
9     Requires: python py2-simplejson py2-sqlalchemy py2-httplib2 cherrypy py2-cheetah yui
10     Requires: py2-cjson py2-mysqldb rotatelogs
11 diego 1.1
12     %prep
13 lat 1.18 %setup -T -b 0 -n WMCore
14     %setup -D -T -b 1 -n DBS3
15 diego 1.1
16     %build
17 lat 1.18 cd ../WMCore
18     python setup.py build_system -s wmc-web
19 diego 1.1
20     %install
21 lat 1.18 cd ../WMCore
22     python setup.py install_system -s wmc-web --prefix=%i
23     cd ../DBS3
24 giffels 1.15 cp -rp %_builddir/DBS3/* %i/
25 lat 1.18 find %i -name '*.egg-info' -exec rm {} \;
26 diego 1.1
27 lat 1.18 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
28 diego 1.1 mkdir -p %i/etc/profile.d
29 lat 1.18 : > %i/etc/profile.d/dependencies-setup.sh
30     : > %i/etc/profile.d/dependencies-setup.csh
31     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
32     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
33     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
34     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
35     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
36     fi
37 diego 1.1 done
38    
39     %post
40 diego 1.14 %{relocateConfig}etc/profile.d/dependencies-setup.*sh
41 giffels 1.15
42     %files
43     %i/
44     %exclude %i/src
45     %exclude %i/Server/JAVA
46     %exclude %i/Server/Http