1 |
ratnik |
1.1 |
|
2 |
|
|
### RPM external dcache-client 1.7.0
|
3 |
|
|
Requires: apache-ant
|
4 |
|
|
%define downloadv %(echo %v | tr . -)
|
5 |
|
|
Source: http://www.dcache.org/downloads/%{v}/dCache-production-%{downloadv}-sources.tar
|
6 |
|
|
%prep
|
7 |
|
|
%setup -n dCacheBuild
|
8 |
|
|
export JAVA_HOME=$JAVA_JDK_ROOT
|
9 |
|
|
export CLASSPATH="."
|
10 |
|
|
%build
|
11 |
|
|
chmod a+x `find modules -type f -name "*.sh"`
|
12 |
|
|
ant dcache-srm > dcache-srm.log 2>&1
|
13 |
|
|
ant all > all.log 2>&1
|
14 |
|
|
%install
|
15 |
|
|
ls dist/d-cache
|
16 |
|
|
tar -cf - -C dist/d-cache/dcap . | tar -C %i -xvvf -
|