ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/dls.spec
Revision: 1.13
Committed: Mon Apr 2 11:37:59 2007 UTC (18 years, 1 month ago) by afanfani
Branch: MAIN
Changes since 1.12: +2 -0 lines
Log Message:
add dbs-client in the dependency env

File Contents

# User Rev Content
1 afanfani 1.12 ### RPM cms dls DLS_dbs_test_0_1
2 eulisse 1.1 ## INITENV +PATH PATH %{i}/Server/SimpleServer
3 afanfani 1.8 ## INITENV +PATH PATH %{i}/Client/bin
4     ## INITENV +PATH PYTHONPATH %{i}/Client/lib
5 elmer 1.2 %define cvstag %v
6 afanfani 1.8 %define compProjectName DLS
7     %define srctree DLS
8     Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=%{srctree}&export=%{compProjectName}&&tag=-r%{cvstag}&output=/DLS.tar.gz
9 afanfani 1.12 Requires: python mysql py2-mysqldb py2-pyxml py2-zsi dbs-client
10 eulisse 1.1 %prep
11     %setup -n DLS
12 eulisse 1.4 perl -p -i -e "s|#!/usr/bin/python|#!/usr/bin/env python|" $(find .)
13 eulisse 1.1 %build
14     %install
15 afanfani 1.8 rm -r Documentation
16     rm -r Import
17    
18     cd Client
19     make
20     rm -r lib/ZSI
21     rm -r lib/*PyXML*
22 afanfani 1.9 rm lib/pyexpat*
23 afanfani 1.8 mkdir -p %{i}/Client/bin
24     mv lib/dls-* %{i}/Client/bin/.
25     mv lib/dli-* %{i}/Client/bin/.
26     cp -r lib %{i}/Client/.
27    
28     cd ..
29     cp -r Server %{i}
30    
31     mkdir -p %{i}/etc/profile.d
32    
33     (echo "#!/bin/sh"; \
34     echo "source $PYTHON_ROOT/etc/profile.d/init.sh"; \
35     echo "source $PY2_PYXML_ROOT/etc/profile.d/init.sh"; \
36 afanfani 1.10 echo "source $PY2_ZSI_ROOT/etc/profile.d/init.sh"; \
37     echo "source $PY2_MYSQLDB_ROOT/etc/profile.d/init.sh"; \
38 afanfani 1.13 echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.sh"; \
39 afanfani 1.10 echo "source $MYSQL_ROOT/etc/profile.d/init.sh";
40 afanfani 1.8 ) > %{i}/etc/profile.d/dependencies-setup.sh
41    
42     (echo "#!/bin/tcsh"; \
43     echo "source $PYTHON_ROOT/etc/profile.d/init.csh"; \
44     echo "source $PY2_PYXML_ROOT/etc/profile.d/init.csh"; \
45 afanfani 1.10 echo "source $PY2_ZSI_ROOT/etc/profile.d/init.csh"; \
46     echo "source $PY2_MYSQLDB_ROOT/etc/profile.d/init.csh"; \
47 afanfani 1.13 echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.csh"; \
48 afanfani 1.10 echo "source $MYSQL_ROOT/etc/profile.d/init.csh";
49 afanfani 1.8 ) > %{i}/etc/profile.d/dependencies-setup.csh
50    
51     %post
52     %{relocateConfig}etc/profile.d/dependencies-setup.sh
53     %{relocateConfig}etc/profile.d/dependencies-setup.csh
54