Revision: | 1.6 |
Committed: | Sun Sep 30 00:46:49 2007 UTC (17 years, 7 months ago) by elmer |
Branch: | MAIN |
CVS Tags: | nr080626_for1612flt, CMSSW_1_6_12, apFor1612v0, apFor1612p3v0, CMSSW_1_6_12_pre2, apFor1612p2v1, apFor1612p2v0, CMSSW_1_6_12_pre1, apFor1612p1v1, apFor1612p1v0, CMSSW_1_6_11, apFor1611v0, apFor1611p1v1, apFor1611p1v0, CMSSW_1_6_10, apFor1610v0, CMSSW_1_6_10_pre2, CMSSW_1_6_10_pre1, apFor1610p2v0, apFor1610p1v2, CMSSW_1_6_8_FWLITE-root51800, apFor1610p1v1, CMSSW_1_6_9, apFor169v1, CMSSW_1_6_9_pre2, nr080124fwl168a, apFor169p2v2, apFor169p2v1, apFor169p2v0, ap20080116d, ap20080116c, ap20080116b, ap20080116a, ap20080115d, ap20080115c, ap20080115b, ap20080115a, ap20080114b, ap20080114a, CMSSW_1_6_9_pre1, apFor169p1, apFor169p1v5, apFor169p1v4, apFor169p1v3, apFor169p1v2, apFor169p1v1, apFor169p1v0, apFor169v0, CMSSW_1_6_8, CMSSW_1_6_8_pre2_FWLITE-root51706, apFor168, CMSSW_1_6_8_pre2, apFor168p2, CMSSW_1_6_8_pre1, apFor168p1, CMSSW_1_6_7_FWLITE, nr071026_fwlite167, nr071025_fwlite167, CMSSW_1_6_7, pe20071019a-for167, CMSSW_1_6_6, pe20071013a-for166p2, pe20071011a-for166, pe20071009a-for166p1, CMSSW_1_6_5, pe20071006a-for165, CMSSW_1_6_5_pre2, pe20071005a-for165p2, CMSSW_1_6_5_pre1, pe20070930b-for165p1 |
Changes since 1.5: | +1 -1 lines |
Log Message: | Update version after latest fixes, for rebuild for 165p1 |
# | User | Rev | Content |
---|---|---|---|
1 | elmer | 1.6 | ### RPM external dpm 1.6.5-5-CMS3p |
2 | muzaffar | 1.1 | ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) true ;; esac |
3 | |||
4 | %define baseVersion %realversion | ||
5 | muzaffar | 1.2 | %define patchLevel %(echo %v | cut -d- -f2) |
6 | %define downloadv %{realversion}-%{patchLevel} | ||
7 | %define dpmarch %(echo %cmsplatf | cut -d_ -f1) | ||
8 | muzaffar | 1.1 | |
9 | muzaffar | 1.2 | Source: http://eticssoft.web.cern.ch/eticssoft/repository/org.glite/LCG-DM/%{realversion}/src/DPM-%{downloadv}sec.%{dpmarch}.src.rpm |
10 | muzaffar | 1.1 | |
11 | elmer | 1.5 | %define cpu %(echo %cmsplatf | cut -d_ -f2) |
12 | %if "%cpu" != "amd64" | ||
13 | %define libsuffix %{nil} | ||
14 | %else | ||
15 | %define libsuffix ()(64bit) | ||
16 | %endif | ||
17 | Provides: libdpm.so%{libsuffix} | ||
18 | |||
19 | muzaffar | 1.1 | %prep |
20 | muzaffar | 1.2 | rm -f %_builddir/DPM-%{realversion}.src.tar.gz |
21 | rpm2cpio %{_sourcedir}/DPM-%{downloadv}sec.%{dpmarch}.src.rpm | cpio -ivd DPM-%{realversion}.src.tar.gz | ||
22 | cd %_builddir ; rm -rf DPM-%{realversion}; tar -xzvf DPM-%{realversion}.src.tar.gz | ||
23 | |||
24 | muzaffar | 1.1 | %build |
25 | muzaffar | 1.2 | cd DPM-%{realversion} |
26 | muzaffar | 1.1 | cp h/patchlevel.in h/patchlevel.h |
27 | perl -pi -e "s!__PATCHLEVEL__!%patchLevel!;s!__BASEVERSION__!\"%baseVersion\"!;s!__TIMESTAMP__!%(date +%%s)!" h/patchlevel.h | ||
28 | perl -pi -e 's|ld\s+\$\(|ld -m elf_i386 \$\(|' shlib/Imakefile | ||
29 | |||
30 | elmer | 1.4 | for this in BuildDLI BuildDPMServer BuildNameServerDaemon BuildNameServerLibrary BuildRfioServer \ |
31 | muzaffar | 1.1 | BuildSRMv1Server BuildSRMv2Server BuildSRMv2_2Server BuildTest ; do |
32 | perl -pi -e "s/\s+$this\s+YES/ $this\tNO/g" config/site.def | ||
33 | done | ||
34 | |||
35 | for this in BuildDPMClient BuildInterfaces BuildRfioClient; do | ||
36 | perl -pi -e "s/\s+$this\s+NO/ $this\tYES/g" config/site.def | ||
37 | done | ||
38 | elmer | 1.4 | for this in Accounting HasNroff UseCupv UseKRB4 UseKRB5 UseMySQL UseOracle UseVirtualIds UseVOMS ; do |
39 | muzaffar | 1.1 | perl -pi -e "s/\s+$this\s+YES/ $this\tNO/g" config/site.def |
40 | done | ||
41 | for this in SecMakeStaticLibrary BuildSecureRfio BuildSecureCns BuildSecureDpm ; do | ||
42 | perl -pi -e "s/\s+$this\s+YES/ $this\tNO/g" config/site.def | ||
43 | done | ||
44 | |||
45 | mkdir -p %i/lib %i/include/dpm | ||
46 | |||
47 | ./configure | ||
48 | cd shlib; make | ||
49 | |||
50 | %install | ||
51 | muzaffar | 1.2 | cd DPM-%{realversion} |
52 | muzaffar | 1.1 | cp ./shlib/lib%n.so %i/lib/lib%n.so.%realversion |
53 | cp ./h/*.h %i/include/dpm | ||
54 | ln -s lib%n.so.%realversion %i/lib/lib%n.so | ||
55 | |||
56 | # SCRAM ToolBox toolfile | ||
57 | mkdir -p %i/etc/scram.d | ||
58 | cat << \EOF_TOOLFILE >%i/etc/scram.d/%n | ||
59 | <doc type=BuildSystem::ToolDoc version=1.0> | ||
60 | <Tool name=%n version=%v> | ||
61 | <lib name=dpm> | ||
62 | <Client> | ||
63 | <Environment name=DPM_BASE default="%i"></Environment> | ||
64 | <Environment name=INCLUDE default="$DPM_BASE/include"></Environment> | ||
65 | <Environment name=LIBDIR default="$DPM_BASE/lib"></Environment> | ||
66 | </Client> | ||
67 | </Tool> | ||
68 | EOF_TOOLFILE | ||
69 | |||
70 | %post | ||
71 | %{relocateConfig}etc/scram.d/%n |