ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/fastjet.spec
Revision: 1.13
Committed: Mon Oct 29 19:44:15 2007 UTC (17 years, 6 months ago) by dlange
Branch: MAIN
CVS Tags: CMSSW_1_7_7, dl080227for176, CMSSW_1_7_5_ONLINE1, CMSSW_1_7_5, CMSSW_1_7_5_g491, CMSSW_1_7_5_ONLINE, nr080115onl175, dl080111, ge20080109-webconddb, ge20080109-sitedb, CMSSW_1_7_4, CMSSW_1_7_3_g490p1, dl071212t2, dl071212, CMSSW_1_7_3, CMSSW_1_7_2, CMSSW_1_7_1, nr071121onl170_xdaq5, nr071120_fwlite170_1, CMSSW_1_7_0_ONLINE, CMSSW_1_7_0, nr071116onlpre13, CMSSW_1_7_0_pre13, dl071114, ap20071113, CMSSW_1_7_0_pre12, CMSSW_1_7_0_pre10_ONLINE, CMSSW_1_7_0_pre11, nr071105a, pe20071102a-ports, CMSSW_1_7_0_pre10, CMSSW_1_7_0_pre9, CMSSW_1_7_0_pre8
Changes since 1.12: +2 -0 lines
Log Message:
new fastjet patch

File Contents

# User Rev Content
1 muzaffar 1.11 ### RPM external fastjet 2.1.0-CMS8
2 elmer 1.8 Source: http://www.lpthe.jussieu.fr/~salam/repository/software/fastjet/%n-%realversion.tgz
3 elmer 1.9 Patch1: fastjet-2.1.0-nobanner
4 dlange 1.13 Patch2: fastjet_sisconebanner
5 elmer 1.9
6 ratnik 1.1 %prep
7 elmer 1.8 %setup -n %n-%realversion
8 elmer 1.9 %patch1 -p1
9 dlange 1.13 %patch2 -p1
10 ratnik 1.1
11     %build
12 elmer 1.3 # The following is a hack, whether it works should be checked whenever
13     # the version is updated from 2.1.0b1
14 elmer 1.12 perl -p -i -e "s|CXXFLAGS \+\= \-O3|CXXFLAGS += -fPIC -O3|" Makefile
15     cd src
16 ratnik 1.1 make
17     make install
18 dlange 1.5 cd ../plugins
19 elmer 1.12 perl -p -i -e "s|CFLAGS \=|CFLAGS = -fPIC|" SISCone/siscone/src/Makefile
20     perl -p -i -e "s|^CXXFLAGSmidpoint \=|CXXFLAGSmidpoint = -fPIC|" CDFCones/CDFcode/Makefile
21 dlange 1.5 make
22     make clean
23    
24     cd ../include/fastjet
25     find ../../plugins/CDFCones -name "*.hh" -exec ln -sf {} \;
26     find ../../plugins/SISCone -name "*.hh" -exec ln -sf {} \;
27    
28     cd ../../lib/
29     find ../plugins/CDFCones -name "*.a" -exec mv {} . \;
30     find ../plugins/SISCone -name "*.a" -exec mv {} . \;
31    
32 ratnik 1.1
33     %install
34 dlange 1.5
35 ratnik 1.1 # Take everything including sources, makefiles, documentation and examples (only 16MB).
36     gtar -cv ./| gtar -x -C %i
37 muzaffar 1.11 # SCRAM ToolBox toolfile
38     mkdir -p %i/etc/scram.d
39     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
40     <doc type=BuildSystem::ToolDoc version=1.0>
41     <Tool name=FastJet version=%v>
42     <info url=http://www.lpthe.jussieu.fr/~salam/fastjet/></info>
43     <lib name=SISConePlugin>
44     <lib name=CDFConesPlugin>
45     <lib name=fastjet>
46     <client>
47     <Environment name=FASTJET_BASE default="%i"></Environment>
48     <Environment name=LIBDIR default="$FASTJET_BASE/lib"></Environment>
49     <Environment name=INCLUDE default="$FASTJET_BASE/include"></Environment>
50     </client>
51     </Tool>
52     EOF_TOOLFILE
53    
54     %post
55     %{relocateConfig}etc/scram.d/%n