ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/fwlite.spec
Revision: 1.7
Committed: Fri Jul 20 22:16:10 2007 UTC (17 years, 9 months ago) by ratnik
Branch: MAIN
Changes since 1.6: +22 -200 lines
Log Message:
Merged with the latest development:
 * now imports scramv1-build.file directly
 * all non-fwlite specific instructions are moved to partial-build.file
 * reads the list of packages from a file (in anticipation for handling
   long lists of packages in online releases)
Compatibility:
 * works with CMSSW/config version V00-02-02, with Shahzad's replacement
   of munging config files, used starting from CMSSW_1_6_0 prereleases
 * compatibility with CMSSW_1_5_0 has not been tested, and may not work
Tests:
 * creates successfully fwlite for CMSSW_1_6_0_pre4
 * tested against JetMet and Oliver's tutorial examples.

File Contents

# User Rev Content
1 ratnik 1.7 ### RPM cms fwlite CMSSW_1_6_0_pre4_FWLITE
2 ratnik 1.1 ## IMPORT configurations
3     Provides: /bin/zsh
4 ratnik 1.7 Requires: fwlite-tool-conf
5     %define cmssw_release %(perl -e '$_="%v"; s/_FWLITE//; print;')
6     %define toolconf ${FWLITE_TOOL_CONF_ROOT}/configurations/tools-STANDALONE.conf
7    
8     #Defines for file containing list of packages for checkout and build:
9     %define buildsetrepo CMSDIST
10     %define buildsetfile fwlite_build_set.file
11     %define buildsetvers V3_0
12    
13     # Define list of external tools to be selected in scram configuration.
14     # Any changes must be propagated in fwlite-tool-conf.spec:
15     %define externals "cxxcompiler ccompiler clhep sockets boost boost_filesystem rootrflx rootcore rootmath gccxml boost_python elementtree sigcpp hepmc gsl boost_regex boost_program_options boost_program_options boost_regex bz2lib pcre root rootcintex zlib glimpse"
16    
17 ratnik 1.1
18     %define prebuildtarget gindices
19     %define buildtarget release-build
20    
21 ratnik 1.7 # Skip library load and symbol checks to avoid dependency on seal:
22     %define nolibchecks on
23 ratnik 1.1
24 ratnik 1.7 # Switch off building tests:
25     %define patchsrc3 perl -p -i -e ' s!(<ClassPath.*test\\+test>)!#$1!;' config/BuildFile
26 ratnik 1.2
27 ratnik 1.7 # Additional source patches named patchsrc4, patchsrc5 can be defined here.
28 ratnik 1.1
29 ratnik 1.7 ## IMPORT cms-scram-build
30     ## IMPORT partial-build
31     ## IMPORT scramv1-build