ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc.spec
Revision: 1.1
Committed: Fri Jan 13 16:54:03 2006 UTC (19 years, 3 months ago) by argiro
Branch: MAIN
Log Message:
Files from IGUANA/Ig_Infrastructure/IgBuildScripts

File Contents

# User Rev Content
1 argiro 1.1 ### RPM external gcc 3.2.3
2     ## BUILDIF [ $(uname) != Darwin ]
3     Source: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%v/%n-%v.tar.gz
4    
5     %build
6     # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
7     # enabling it causes qt's uic to die with segmentation violation half
8     # way down the build of qt (projecsettings.ui or something like that;
9     # not the first or only call to uic). Disabling the flag removes the
10     # issue, so clearly the option does not work correctly on this
11     # platform combination.
12     mkdir -p obj
13     cd obj
14     ../configure --prefix=%i --enable-languages=c,c++,f77 \
15     --enable-shared # --enable-__cxa_atexit
16     make bootstrap
17    
18     %install
19     cd obj && make install
20     ln -s gcc %i/bin/cc