ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc.spec
Revision: 1.12
Committed: Sat Apr 7 03:48:52 2007 UTC (18 years ago) by elmer
Branch: MAIN
CVS Tags: pe20070501b-ports, pe20070501a-ports, pe20070428a-ports, pe20070423b-ports, pe20070423a-ports, pe20070414b-ports, pe20070414a-ports, pe20070412b-ports, pe20070412a-ports, pe20070411a-ports, pe20070409a-ports, pe20070407a-ports
Changes since 1.11: +1 -1 lines
Log Message:
Switch the BUILDIF from a simple !Darwin to a case statement, excluding
Darwin and Linux:ppc64

File Contents

# User Rev Content
1 lat 1.10 ### RPM external gcc 3.4.5
2 eulisse 1.3 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
4 elmer 1.12 ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) true ;; esac
5 eulisse 1.3 Source: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%v/%n-%v.tar.bz2
6 eulisse 1.11 %define cpu %(echo %cmsplatf | cut -d_ -f2)
7 argiro 1.1 %build
8     # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
9     # enabling it causes qt's uic to die with segmentation violation half
10     # way down the build of qt (projecsettings.ui or something like that;
11     # not the first or only call to uic). Disabling the flag removes the
12     # issue, so clearly the option does not work correctly on this
13     # platform combination.
14     mkdir -p obj
15     cd obj
16 eulisse 1.3
17     if [ "`echo %v | cut -d. -f 1`" == "3" ]
18     then
19 argiro 1.1 ../configure --prefix=%i --enable-languages=c,c++,f77 \
20     --enable-shared # --enable-__cxa_atexit
21 eulisse 1.3 else
22     ../configure --prefix=%i --enable-languages=c,c++ \
23     --enable-shared # --enable-__cxa_atexit
24     fi
25 eulisse 1.2 make %makeprocesses bootstrap
26 argiro 1.1
27     %install
28     cd obj && make install
29     ln -s gcc %i/bin/cc
30 eulisse 1.9 %post
31     %{relocateConfig}lib/libg2c.la
32     %{relocateConfig}lib/libstdc++.la
33     %{relocateConfig}lib/libsupc++.la
34 eulisse 1.11 %if "%cpu" == "amd64"
35     %{relocateConfig}lib64/libg2c.la
36     %{relocateConfig}lib64/libstdc++.la
37     %{relocateConfig}lib64/libsupc++.la
38     %{relocateConfig}lib/32/libg2c.la
39     %{relocateConfig}lib/32/libstdc++.la
40     %{relocateConfig}lib/32/libsupc++.la
41     %endif