ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc.spec
Revision: 1.13
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.12: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 lat 1.10 ### RPM external gcc 3.4.5
2 ratnik 1.13 Requires: gcc-wrapper
3 eulisse 1.3 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
4     ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
5 elmer 1.12 ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) true ;; esac
6 eulisse 1.3 Source: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%v/%n-%v.tar.bz2
7 eulisse 1.11 %define cpu %(echo %cmsplatf | cut -d_ -f2)
8 argiro 1.1 %build
9 ratnik 1.13 ## IMPORT gcc-wrapper
10 argiro 1.1 # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
11     # enabling it causes qt's uic to die with segmentation violation half
12     # way down the build of qt (projecsettings.ui or something like that;
13     # not the first or only call to uic). Disabling the flag removes the
14     # issue, so clearly the option does not work correctly on this
15     # platform combination.
16     mkdir -p obj
17     cd obj
18 eulisse 1.3
19     if [ "`echo %v | cut -d. -f 1`" == "3" ]
20     then
21 argiro 1.1 ../configure --prefix=%i --enable-languages=c,c++,f77 \
22     --enable-shared # --enable-__cxa_atexit
23 eulisse 1.3 else
24     ../configure --prefix=%i --enable-languages=c,c++ \
25     --enable-shared # --enable-__cxa_atexit
26     fi
27 eulisse 1.2 make %makeprocesses bootstrap
28 argiro 1.1
29     %install
30     cd obj && make install
31     ln -s gcc %i/bin/cc
32 eulisse 1.9 %post
33     %{relocateConfig}lib/libg2c.la
34     %{relocateConfig}lib/libstdc++.la
35     %{relocateConfig}lib/libsupc++.la
36 eulisse 1.11 %if "%cpu" == "amd64"
37     %{relocateConfig}lib64/libg2c.la
38     %{relocateConfig}lib64/libstdc++.la
39     %{relocateConfig}lib64/libsupc++.la
40     %{relocateConfig}lib/32/libg2c.la
41     %{relocateConfig}lib/32/libstdc++.la
42     %{relocateConfig}lib/32/libsupc++.la
43     %endif