ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc.spec
Revision: 1.18
Committed: Mon May 7 13:49:43 2007 UTC (17 years, 11 months ago) by eulisse
Branch: MAIN
Changes since 1.17: +80 -12 lines
Log Message:
* Support for gfortran added.

File Contents

# User Rev Content
1 eulisse 1.18 ### RPM external gcc 4.1.2
2 eulisse 1.3 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
3 eulisse 1.16 ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
4 elmer 1.12 ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) true ;; esac
5 dlange 1.17 %define realversion %(echo %v | cut -d- -f1 )
6     Source0: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%realversion/%n-%realversion.tar.bz2
7 eulisse 1.16 %define binutilsv 2.17
8     Source1: http://ftp.gnu.org/gnu/binutils/binutils-%binutilsv.tar.bz2
9 eulisse 1.18
10     # If gcc version >= 4.0.0, we need two additional sources, for gmp and mpfr,
11     # and we set the fortranCompiler macro (which is going to be used by the
12     # --enable-languages option of gcc's configure) to gfortran.
13     # Notice that we need to build those twice: once using the system compiler
14     # and the using the newly built gcc.
15     # I also set the convenience macro gcc4 to ease gcc detection.
16     %define gmpVersion 4.2.1
17     %define mpfrVersion 2.2.1
18     Source2: ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmpVersion}.tar.bz2
19     Source3: http://www.mpfr.org/mpfr-current/mpfr-%{mpfrVersion}.tar.bz2
20     %if "%(echo %v | cut -f1 -d. )" == "4"
21     %define gcc4 true
22     %define firstStepFortran %{nil}
23     %define fortranCompiler ,fortran
24     %else
25     %define firstStepFortran ,f77
26     %define fortranCompiler ,f77
27     %endif
28    
29    
30 eulisse 1.11 %define cpu %(echo %cmsplatf | cut -d_ -f2)
31 eulisse 1.16 %prep
32 dlange 1.17 %setup -T -b 0 -n gcc-%realversion
33 dlange 1.15
34 eulisse 1.16 %if "%cmsos" == "slc4_ia32"
35     cat << \EOF_CONFIG_GCC >> gcc/config.gcc
36     # CMS patch to include gcc/config/i386/t-cms when building gcc
37     tm_file="$tm_file i386/cms.h"
38     tmake_file="$tmake_file i386/t-cms"
39     EOF_CONFIG_GCC
40    
41     cat << \EOF_CMS_H > gcc/config/i386/cms.h
42     #define ASM_SPEC "%%{v:-V} %%{Qy:} %%{!Qn:-Qy} %%{n} %%{T} %%{Ym,*} %%{Yd,*} %%{Wa,*:%%*} --32"
43     #define CC1_SPEC "%%(cc1_cpu) %%{profile:-p} -m32"
44     #define CC1PLUS_SPEC "-m32"
45     #define MULTILIB_DEFAULTS { "m32" }
46     EOF_CMS_H
47    
48     cat << \EOF_T_CMS > gcc/config/i386/t-cms
49     MULTILIB_OPTIONS = m32
50     MULTILIB_DIRNAMES = ../lib
51     MULTILIB_MATCHES = m32=m32
52     EOF_T_CMS
53     %endif
54 dlange 1.15
55 eulisse 1.16 #perl -p -i -e 's|SPECS = specs|SPECS = specs.install|' gcc/Makefile.in
56     %setup -D -T -b 1 -n binutils-%binutilsv
57 eulisse 1.18
58     # We need to setup gmp and mpfr as well if the compiler version is >= 4.0.0.
59     %if "%{?gcc4:set}" == "set"
60     %setup -D -T -b 2 -n gmp-%{gmpVersion}
61     %setup -D -T -b 3 -n mpfr-%{mpfrVersion}
62     %endif
63    
64 argiro 1.1 %build
65     # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
66     # enabling it causes qt's uic to die with segmentation violation half
67     # way down the build of qt (projecsettings.ui or something like that;
68     # not the first or only call to uic). Disabling the flag removes the
69     # issue, so clearly the option does not work correctly on this
70     # platform combination.
71 eulisse 1.3
72 eulisse 1.18
73     # The buildGCC function is an utility function to ease the creation of
74     # cross compilers.
75 eulisse 1.16 buildGCC () {
76     target=$1
77     host=$2
78     prefix=$3
79    
80     if [ "X$target" != "X" ]
81     then
82     targetOption="--target $target"
83     fi
84    
85     if [ "X$host" != "X" ]
86     then
87     hostOption="--host $host"
88     fi
89    
90 eulisse 1.18 languages=c,c++%{fortranCompiler}
91 eulisse 1.16
92     if [ "$prefix" == "" ]
93     then
94     prefix=%i
95     fi
96    
97     mkdir -p obj-$target
98     cd obj-$target
99 eulisse 1.18
100 eulisse 1.16 ../configure --prefix=$prefix --enable-languages=$languages \
101     --enable-shared \
102 eulisse 1.18 %if "%{gcc4}" == "true"
103     --with-gmp-dir=%_builddir/gmp-%{gmpVersion} \
104     --with-mpfr-dir=%_builddir/mpfr-%{mpfrVersion} \
105     %endif
106 eulisse 1.16 $targetOption \
107     $hostOption
108 eulisse 1.18 make %makeprocesses bootstrap
109 eulisse 1.16 make install
110     cd ..
111     }
112    
113     # create a tmp
114     mkdir -p %i/tmp
115    
116     # build the latest/greatest binutils
117     mkdir -p %i/tmp/binutils
118     cd ../binutils-%{binutilsv}
119     ./configure --prefix=%i/tmp/binutils
120     make %makeprocesses
121     make install
122 eulisse 1.18 export PATH=%i/tmp/binutils/bin:$PATH
123     export LD_LIBRARY_PATH=%i/tmp/binutils/lib:$PATH
124 eulisse 1.16
125     # build the native platform compiler
126 eulisse 1.18 cd ../gcc-%v
127     mkdir -p obj
128     cd obj
129     ../configure --prefix=%i --enable-languages=c,c++%{firstStepFortran} \
130     --enable-shared
131    
132     make %makeprocesses bootstrap
133     make install
134     cd ..
135 eulisse 1.16
136     # rebuild binutils with the new compiler
137     export PATH=%i/bin:$PATH
138     export LD_LIBRARY_PATH=%i/lib:$PATH
139     cd ../binutils-%binutilsv
140     ./configure --prefix=%i
141     make %makeprocesses
142     make install
143     rm -fr %i/tmp
144    
145 eulisse 1.18 # And if we are building gcc4, we build gmp and mpfr as well and then rebuild gcc4 with fortran support.
146     %if "%{?gcc4:set}" == "set"
147     cd ../gmp-%{gmpVersion}
148     ./configure --prefix=%i
149     make %makeprocesses
150     make install
151    
152     cd ../mpfr-%{mpfrVersion}
153     ./configure --prefix=%i --with-gmp=%i
154     make %makeprocesses
155     make install
156    
157     cd ../gcc-%{v}/obj
158     make distclean
159     cd ..
160    
161     buildGCC
162    
163     %endif
164 argiro 1.1
165     %install
166 eulisse 1.16 #cd obj && make install
167 argiro 1.1 ln -s gcc %i/bin/cc
168 eulisse 1.9 %post
169     %{relocateConfig}lib/libg2c.la
170     %{relocateConfig}lib/libstdc++.la
171     %{relocateConfig}lib/libsupc++.la
172 eulisse 1.11 %if "%cpu" == "amd64"
173     %{relocateConfig}lib64/libg2c.la
174     %{relocateConfig}lib64/libstdc++.la
175     %{relocateConfig}lib64/libsupc++.la
176     %{relocateConfig}lib/32/libg2c.la
177     %{relocateConfig}lib/32/libstdc++.la
178     %{relocateConfig}lib/32/libsupc++.la
179     %endif
180 eulisse 1.18 %if "%gcc4" == "true"
181     %{relocateConfig}lib/libbfd.la
182     %{relocateConfig}lib/libgmp.la
183     %{relocateConfig}lib/libopcodes.la
184     %{relocateConfig}lib/libmudflap.la
185     %{relocateConfig}lib/libgfortran.la
186     %{relocateConfig}lib/libmudflapth.la
187     %{relocateConfig}lib/libmpfr.la
188     %{relocateConfig}lib/libssp.la
189     %{relocateConfig}lib/libgfortranbegin.la
190     %endif