ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc.spec
Revision: 1.23
Committed: Fri Jun 22 10:05:25 2007 UTC (17 years, 10 months ago) by eulisse
Branch: MAIN
CVS Tags: ge20070709-slc3
Changes since 1.22: +1 -1 lines
Log Message:
*Uses gcc 3.2.3

File Contents

# User Rev Content
1 eulisse 1.23 ### RPM external gcc 3.2.3-wt1
2 eulisse 1.3 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
3 eulisse 1.16 ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
4 elmer 1.12 ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) true ;; esac
5 dlange 1.17 Source0: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%realversion/%n-%realversion.tar.bz2
6 eulisse 1.16 %define binutilsv 2.17
7     Source1: http://ftp.gnu.org/gnu/binutils/binutils-%binutilsv.tar.bz2
8 eulisse 1.18
9     # If gcc version >= 4.0.0, we need two additional sources, for gmp and mpfr,
10     # and we set the fortranCompiler macro (which is going to be used by the
11     # --enable-languages option of gcc's configure) to gfortran.
12     # Notice that we need to build those twice: once using the system compiler
13     # and the using the newly built gcc.
14     %define gmpVersion 4.2.1
15     %define mpfrVersion 2.2.1
16     Source2: ftp://ftp.gnu.org/gnu/gmp/gmp-%{gmpVersion}.tar.bz2
17     Source3: http://www.mpfr.org/mpfr-current/mpfr-%{mpfrVersion}.tar.bz2
18    
19 eulisse 1.11 %define cpu %(echo %cmsplatf | cut -d_ -f2)
20 eulisse 1.16 %prep
21 dlange 1.17 %setup -T -b 0 -n gcc-%realversion
22 dlange 1.15
23 eulisse 1.16 %if "%cmsos" == "slc4_ia32"
24     cat << \EOF_CONFIG_GCC >> gcc/config.gcc
25     # CMS patch to include gcc/config/i386/t-cms when building gcc
26     tm_file="$tm_file i386/cms.h"
27     tmake_file="$tmake_file i386/t-cms"
28     EOF_CONFIG_GCC
29    
30     cat << \EOF_CMS_H > gcc/config/i386/cms.h
31 eulisse 1.20 #undef ASM_SPEC
32 eulisse 1.16 #define ASM_SPEC "%%{v:-V} %%{Qy:} %%{!Qn:-Qy} %%{n} %%{T} %%{Ym,*} %%{Yd,*} %%{Wa,*:%%*} --32"
33 eulisse 1.20 #undef CC1_SPEC
34 eulisse 1.16 #define CC1_SPEC "%%(cc1_cpu) %%{profile:-p} -m32"
35 eulisse 1.20 #undef CC1PLUS_SPEC
36 eulisse 1.16 #define CC1PLUS_SPEC "-m32"
37 eulisse 1.20 #undef MULTILIB_DEFAULTS
38 eulisse 1.16 #define MULTILIB_DEFAULTS { "m32" }
39     EOF_CMS_H
40    
41     cat << \EOF_T_CMS > gcc/config/i386/t-cms
42     MULTILIB_OPTIONS = m32
43     MULTILIB_DIRNAMES = ../lib
44     MULTILIB_MATCHES = m32=m32
45     EOF_T_CMS
46     %endif
47 dlange 1.15
48 eulisse 1.16 %setup -D -T -b 1 -n binutils-%binutilsv
49 eulisse 1.18 %setup -D -T -b 2 -n gmp-%{gmpVersion}
50     %setup -D -T -b 3 -n mpfr-%{mpfrVersion}
51    
52 argiro 1.1 %build
53 eulisse 1.20 # Set special variables required to build 32-bit executables on 64-bit
54     # systems. Note that if the architecture is SLC4/IA32, we may be on a
55     # 64-bit system and need to produce a 32-bit capable compiler, which
56     # _itself_ is a 32-bit executable.
57     case $(uname -m):%{cmsos} in
58     *:slc4_ia32 )
59     CCOPTS="-m32 -Wa,--32" ;;
60     * )
61     CCOPTS="" ;;
62     esac
63    
64     # If requested, build our own binutils. Currently the default is to use
65     # the system binutils.
66     %if "%{?use_external_binutils:set}" == "set"
67     cd ../binutils-%{binutilsv}
68     CC="gcc $CCOPTS" ./configure --prefix=%i
69     make %makeprocesses
70     make install
71 eulisse 1.18 %endif
72 eulisse 1.16
73 eulisse 1.20 # Build GMP/MPFR for GCC 4.x
74 eulisse 1.19 cd ../gmp-%{gmpVersion}
75 eulisse 1.20 CC="gcc $CCOPTS" ./configure --prefix=%i/tmp/gmp --disable-shared
76 eulisse 1.19 make %makeprocesses
77 eulisse 1.20 make install
78 eulisse 1.19
79     cd ../mpfr-%{mpfrVersion}
80 eulisse 1.20 CC="gcc $CCOPTS" ./configure --prefix=%i/tmp/mpfr --with-gmp=%i/tmp/gmp --disable-shared
81 eulisse 1.19 make %makeprocesses
82    
83 eulisse 1.20 # Build the compilers
84 elmer 1.21 cd ../gcc-%realversion
85 eulisse 1.18 mkdir -p obj
86     cd obj
87 eulisse 1.20 CC="gcc $CCOPTS" \
88     ../configure --prefix=%i \
89     --enable-languages=c,c++,`case %v in 3.*) echo f77;; *) echo fortran;; esac` \
90     --with-gmp-dir=%_builddir/gmp-%{gmpVersion} \
91     --with-mpfr-dir=%_builddir/mpfr-%{mpfrVersion} \
92     --enable-shared
93 eulisse 1.18
94     make %makeprocesses bootstrap
95 eulisse 1.16
96 argiro 1.1 %install
97 elmer 1.21 cd %_builddir/gcc-%{realversion}/obj && make install
98 argiro 1.1 ln -s gcc %i/bin/cc
99 eulisse 1.20 find %i/lib %i/lib32 %i/lib64 -name '*.la' -exec rm -f {} \; || true
100    
101 eulisse 1.9 %post
102 eulisse 1.20 # %{relocateConfig}lib/libg2c.la
103     # %{relocateConfig}lib/libstdc++.la
104     # %{relocateConfig}lib/libsupc++.la
105     # %if "%cpu" == "amd64"
106     # %{relocateConfig}lib64/libg2c.la
107     # %{relocateConfig}lib64/libstdc++.la
108     # %{relocateConfig}lib64/libsupc++.la
109     # %{relocateConfig}lib/32/libg2c.la
110     # %{relocateConfig}lib/32/libstdc++.la
111     # %{relocateConfig}lib/32/libsupc++.la
112     # %endif
113     # %if "%gcc4" == "true"
114     # %{relocateConfig}lib/libgfortran.la
115     # %{relocateConfig}lib/libgfortranbegin.la
116     # %endif