1 |
argiro |
1.1 |
### RPM external gcc 3.2.3
|
2 |
|
|
## BUILDIF [ $(uname) != Darwin ]
|
3 |
|
|
Source: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%v/%n-%v.tar.gz
|
4 |
|
|
|
5 |
|
|
%build
|
6 |
|
|
# FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
|
7 |
|
|
# enabling it causes qt's uic to die with segmentation violation half
|
8 |
|
|
# way down the build of qt (projecsettings.ui or something like that;
|
9 |
|
|
# not the first or only call to uic). Disabling the flag removes the
|
10 |
|
|
# issue, so clearly the option does not work correctly on this
|
11 |
|
|
# platform combination.
|
12 |
|
|
mkdir -p obj
|
13 |
|
|
cd obj
|
14 |
|
|
../configure --prefix=%i --enable-languages=c,c++,f77 \
|
15 |
|
|
--enable-shared # --enable-__cxa_atexit
|
16 |
eulisse |
1.2 |
make %makeprocesses bootstrap
|
17 |
argiro |
1.1 |
|
18 |
|
|
%install
|
19 |
|
|
cd obj && make install
|
20 |
|
|
ln -s gcc %i/bin/cc
|