ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc.spec
Revision: 1.11
Committed: Tue Feb 6 23:14:04 2007 UTC (18 years, 2 months ago) by eulisse
Branch: MAIN
CVS Tags: CMSSW_1_5_4, CMSSW_1_5_3, dl070725, CMSSW_1_5_2, CMSSW_1_5_1, dl070629t2, dl070629, CMSSW_1_3_1_HLT6-slc4, CMSSW_1_5_0-ignominy470, CMSSW_1_4_5-slc4, CMSSW_1_5_0, dl070621, CMSSW_1_5_0_pre6, CMSSW_1_4_4-slc4, dl070616, ap-144-slc4, nrFWLITE_150pre5_noseal_newboost, dl070615, dl070614xdaq, dl070614, ap-143g483-slc4, CMSSW_1_4_3-slc4, CMSSW_1_3_1_HLT5-slc4, CMSSW_1_5_0_pre5, dl070602t2, dl070602, CMSSW_1_5_0_pre4, nrFWLITE_150pre4, CMSSW_1_4_2-slc4, CMSSW_1_3_1_HLT4-slc4, dl070522_150pre4cand, CMSSW_1_4_1-slc4, CMSSW_1_5_0_pre3, pe20070518c, pe20070518b, pe20070518a, CMSSW_1_4_0_DAQ1-slc4, pe20070517-for150p3ext, CMSSW_1_3_1_HLT3-slc4, ap-140daq1-1-slc4, CMSSW_1_3_3-slc4, ap-140-1-slc4, CMSSW_1_4_0_pre7, CMSSW_1_3_2-slc4, CMSSW_1_5_0_pre2, dl070505t3, dl070505t2, dl070505, ap-140p7-1-slc4, ap-140p6-1-slc4, ap-140p5-1-slc4, dl070501, pe20070429-for131hlt2-slc4, CMSSW_1_5_0_pre1, dl070428_for140pre5slc4t2, dl070428_for140pre5slc4, pe20070428b, pe20070428a, CMSSW_1_4_0_pre4, pe20070425c-for150p1, pe20070525b-slc4, pe20070525a, pe20070424b-slc4, pe20070424a-slc4, pe20070424-slc4, pe20070423b-slc4, pe20070423a-slc4, pe20070422b-slc4, pe20070422a-slc4, CMSSW_1_3_1-slc4, dl070407, dl070406t2, pe20070407-ports, dl070406, CMSSW_1_4_0_pre3, nrCMSSW_1_4_0_pre3_rc0-slc4, nr070403_cms147-slc4, pe20070401, dl070330, nrCMSSW_1_4_0_pre2_rc3-slc4, CMSSW_1_3_0-slc4, nrCMSSW_1_4_0_pre2_rc2-slc4, dl070327, nr070327_frontier-slc4, nrCMSSW_1_4_0_pre2_rc1-slc4, nrCMSSW_1_4_0_pre2_rc0, CMSSW_1_4_0_pre1-cand-slc4, CMSSW_1_3_0_pre6-slc4t2, CMSSW_1_3_0_pre6-slc4, POOL_2_4_9-p2-slc4, nrCMSSW_1_3_0_pre5-m32, CORAL_1_7_1-slc4, nr20070307_130pre5-m32-slc4, nr20070307_m32, CMSSW_1_3_0_pre5-slc4, nr070301_amd64m32, CMSSW_1_3_0_pre4-slc4-p1, CMSSW_1_3_0_pre4-slc4, CMS_145_2-slc4, CMSSW_1_3_0_pre3-slc4, sfa120207slc4_p1, sfa120207slc4, nr070211_cms144a_2-p1slc4, nr070210_cms144a_2-p1slc4, cms145pre5-slc4, GE20070207
Changes since 1.10: +9 -2 lines
Log Message:
relocates .la correctly on 64bit architectures.

File Contents

# User Rev Content
1 lat 1.10 ### RPM external gcc 3.4.5
2 eulisse 1.3 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
4 argiro 1.1 ## BUILDIF [ $(uname) != Darwin ]
5 eulisse 1.3 Source: ftp://ftp.fu-berlin.de/unix/gnu/%n/%n-%v/%n-%v.tar.bz2
6 eulisse 1.11 %define cpu %(echo %cmsplatf | cut -d_ -f2)
7 argiro 1.1 %build
8     # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
9     # enabling it causes qt's uic to die with segmentation violation half
10     # way down the build of qt (projecsettings.ui or something like that;
11     # not the first or only call to uic). Disabling the flag removes the
12     # issue, so clearly the option does not work correctly on this
13     # platform combination.
14     mkdir -p obj
15     cd obj
16 eulisse 1.3
17     if [ "`echo %v | cut -d. -f 1`" == "3" ]
18     then
19 argiro 1.1 ../configure --prefix=%i --enable-languages=c,c++,f77 \
20     --enable-shared # --enable-__cxa_atexit
21 eulisse 1.3 else
22     ../configure --prefix=%i --enable-languages=c,c++ \
23     --enable-shared # --enable-__cxa_atexit
24     fi
25 eulisse 1.2 make %makeprocesses bootstrap
26 argiro 1.1
27     %install
28     cd obj && make install
29     ln -s gcc %i/bin/cc
30 eulisse 1.9 %post
31     %{relocateConfig}lib/libg2c.la
32     %{relocateConfig}lib/libstdc++.la
33     %{relocateConfig}lib/libsupc++.la
34 eulisse 1.11 %if "%cpu" == "amd64"
35     %{relocateConfig}lib64/libg2c.la
36     %{relocateConfig}lib64/libstdc++.la
37     %{relocateConfig}lib64/libsupc++.la
38     %{relocateConfig}lib/32/libg2c.la
39     %{relocateConfig}lib/32/libstdc++.la
40     %{relocateConfig}lib/32/libsupc++.la
41     %endif