ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcc3-toolfile.spec
Revision: 1.2
Committed: Tue May 8 15:53:43 2007 UTC (17 years, 11 months ago) by eulisse
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +0 -0 lines
State: FILE REMOVED
Error occurred while calculating annotation data.
Log Message:
Old attempt to have toolfiles in a separate spec. A better approach is to keep them within the specfile of the tool they refer to.

File Contents

# Content
1 ### RPM configuration gcc3-toolfile 3.2.3
2 ## IMPORT scramtoolbox-common
3
4 Source: none
5
6 %build
7 %install
8 mkdir -p %toolConfDir %toolBoxDir/Compilers/CXX
9
10 cat << \EOF_gcc3_TOOLCONF_FRAGMENT > %toolConfDir/gcc3.conf
11 TOOL:gcc3
12 +GCC_BASE:${GCC_ROOT}
13 +PATH:${GCC_ROOT}/bin
14 +LIBDIR:${GCC_ROOT}/lib
15 +INCLUDE:${GCC_ROOT}/include
16 EOF_gcc3_TOOLCONF_FRAGMENT
17
18 cat << \EOF_gcc3_TOOLFILE > %toolBoxDir/Compilers/CXX/gcc3
19 <doc type=BuildSystem::ToolDoc version=1.0>
20 <tool name=%toolname version=%v>
21 <client>
22 <environment name=GCC_BASE>
23 The top of the gcc distribution.
24 </environment>
25 <environment name=CXX default="$GCC_BASE/bin/c++" type=bin>
26 The gcc 3 C++ compiler executable
27 </environment>
28 <environment name=CC default="$GCC_BASE/bin/gcc" type=bin>
29 The gcc 3 C compiler executable
30 </environment>
31 <environment name=CCcompiler value="gcc3">
32 Compiler ID
33 </environment>
34 </client>
35 <architecture name=sl>
36 <client>
37 <environment name=LD_LIBRARY_PATH value="$GCC_BASE/lib:$GCC_BASE/lib64:/usr/lib64:/user/X11R6/lib64" type=Runtime_path></environment>
38 <environment name=GCC_EXEC_PREFIX value="$GCC_BASE/lib/gcc-lib/" type=></environment>
39 </client>
40 <makefile>
41
42 # Set the extension for object files and executables:
43 objext := o
44 exeext :=
45
46 # -- interface with SCRAM hardcoded rules
47 # Make insists on chaining together variable defs using "+=".
48 # This means that the C compiler variable CC is incorrect because CC
49 # is already defined. So remove first CC def:
50 CC := $(wordlist 2,$(words $(CC)),$(CC))
51 BFARCH:=Linux24-gcc3
52
53 # Beginning of C var defs:
54 CDebugFlag = -g
55
56 SClinkCmd=$(CC) -pthread $(CFLAGS) $(COptimised) $(LDFLAGS) $< -o $@
57 SClinkCmd_d=$(CC) -pthread $(CFLAGS) $(CDebugFlag) $(LDFLAGS) $< -o $@
58 ClinkCmd=$(SClinkCmd) -pthread $(LDLIBS)
59 ClinkCmdDebug=$(SClinkCmd_d) $(LDLIBS_D)
60 ClinkCmdDebugLocal=$(SClinkCmd_d) $(LDLIBS_D_L)
61 ClinkCmdInsure=$(Insure) -pthread $(CFLAGS) $(CDebugFlag) $(LDFLAGS) $< -o $@ $(LDLIBS_Insure)
62 InsureSharedCTool = $(DebugSharedCTool)
63 DependencyCTool = $(CC) -pthread -M $(CPPFLAGS) $(DependIncludes) $^ > $@
64 PreProcessorCTool = $(CC) -pthread -E $(CPPFLAGS) $^ -o $@
65
66 SharedCObjectFlags = -fPIC
67 SharedCTool = $(CC) -pthread $(CSharedFlags) $^ -o $@ -shared -Wl,-soname,$@ $(CSharedLink)
68 DebugSharedCTool = $(CC) -pthread $(CSharedFlags) $(CDebugFlag) $^ -o $@ -shared -Wl,-soname,$@ $(CSharedLink)
69
70 # Beginning of C++ var defs:
71 CXXDebugFlag=-g
72
73 SCClinkCmd=$(CXX) -pthread $(CXXFLAGS) $(CXXOptimised) $(LDFLAGS) $< -o $@
74 SCClinkCmd_d=$(CXX) -pthread $(CXXFLAGS) $(CXXDebugFlag) $(LDFLAGS) $< -o $@
75 CClinkCmd=$(SCClinkCmd) $(LDLIBS)
76 CClinkCmdDebug=$(SCClinkCmd_d) $(LDLIBS_D)
77 CClinkCmdDebugLocal=$(SCClinkCmd_d) $(LDLIBS_D_L)
78 CClinkCmdInsure=$(Insure) -pthread $(CXXFLAGS) $(CXXDebugFlag) $(LDFLAGS) $< -o $@ $(LDLIBS_Insure)
79 InsureSharedCCTool = $(DebugSharedCCTool)
80 DependencyCCTool = $(CXX) -pthread -MM $(CPPFLAGS) $(CXXFLAGS) $(DependIncludes) $^ > $@
81
82 SharedCCObjectFlags = -fPIC
83 SharedSuffix =so
84 SharedCCTool = $(CXX) -pthread $(CXXSharedFlags) $^ -o $@ -shared -Wl,-soname,$@ $(CXXSharedLink)
85 DebugSharedCCTool = $(CXX) -pthread $(CXXSharedFlags) $(CXXDebugFlag) $^ -o $@ -shared -Wl,-soname,$@ $(CXXSharedLink)
86 PreProcessorCCTool = $(CXX) -pthread -E $(CPPFLAGS) $^ -o $@
87 ifdef g77
88 extralib+=g2c m
89 endif
90
91 </makefile>
92 </architecture>
93 </tool>
94 EOF_gcc3_TOOLFILE
95 %files
96 %toolBoxDir/Compilers/CXX/gcc3
97 %toolConfDir/gcc3.conf