ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gccxml.spec
Revision: 1.15
Committed: Mon Nov 12 01:30:39 2007 UTC (17 years, 5 months ago) by elmer
Branch: MAIN
CVS Tags: CMSSW_1_8_4, pe20080405-for184, CMSSW_1_8_3, pe20080326-for183, pe20080325-for183, CMSSW_1_8_2, pe20080324-for182, nr080320a, CMSSW_1_8_1, nr080314_181onl1, pe20080314-for181, CMSSW_1_8_0_ONLINE1, nr080310_180onl1, nr080307onl180onl1, CMSSW_1_8_0, pe20080304a-for180, pe20080303a-for18X, CMSSW_1_8_0_pre10, pe20080226-for180p10, pe20080220a-for18X, CMSSW_1_8_0_pre9, nr080215g491p01dbg, CMSSW_2_0_0_pre1, CMSSW_1_8_0_pre8, dl080202, pe20080126-for180p8, CMSSW_1_8_0_pre7, pe20080122a-for180p7, dl080120, pe20080120a-for180p7, pe20080117b-for180p7, pe20080117-for180p7, dl080115, CMSSW_1_8_0_pre6, NR080108_geant491-dbg-global, sm20080101a-newscram, pe20071127-ports, pe20071226c-for180p6, pe20071226b-for180p6, pe20071226a-for180p6, pe20071220b-for180p6, pe20071220-for180p6, CMSSW_1_8_0_pre5, pe20071216-for180p5, CMSSW_1_8_0_pre4-vg330, ge20071212-perfreport, pe20071207-for180p4g491c3, NR071206_geant491cand3-global, pe20071206-for180test1, CMSSW_1_8_0_pre4, pe20071205b-for180p4, pe20071205-for180p4, CMSSW_1_8_0_pre3a, pe20071201b-for180p3a, pe20071201-for180p3a, pe20071130-for180p3, pe20071129-for180p3, CMSSW_1_8_0_pre2, CMSSW_1_8_0_pre0-amd64, CMSSW_1_8_0_pre0, pe20071123c-ports, pe20071123b-ports, pe20071123a-ports, pe20071121a-ports, pe20071112b-ports
Changes since 1.14: +21 -19 lines
Log Message:
Updated to correct patch ordering for 0.6.0_patch4 (I had this fix by
hand in my test build area, but hadn't yet committed it)

File Contents

# Content
1 ### RPM external gccxml 0.6.0-CMS18
2 # or gccxml 0.7.0_20070615-CMS18
3 %define gccxmlmajorver %(echo %realversion | cut -f1,2 -d.)
4 Requires: cmake
5 # The next 5 lines are needed for 0.6.0
6 Source: http://www.gccxml.org/files/v0.6/%n-%realversion.tar.gz
7 Patch1: gccxml1
8 Patch2: gccxml2
9 Patch3: gccxml3
10 Patch4: gccxml4
11 # The next 2 lines are needed for 0.7.0_20070615
12 #Source: http://www.gccxml.org/files/v0.6/%n-%realversion.tar.gz
13 #Patch5: gccxml-0.7.0-version
14
15 %prep
16 %setup -n %{n}-%{realversion} # for 0.6.0 (this and next line)
17 %patch2 -p1
18 # For 0.7.0 (next 2 lines)
19 #%setup -n %{n}
20 #%patch5 -p1
21
22 %build
23 mkdir gccxml-build
24 cd gccxml-build
25 cmake -DCMAKE_INSTALL_PREFIX:PATH=%i ..
26 make %makeprocesses
27
28 %install
29 cd gccxml-build
30 make install
31 cd %i
32 # For 0.6.0 (next 4 lines)
33 patch -p1 <%{_sourcedir}/gccxml1
34 patch -p1 <%{_sourcedir}/gccxml3
35 cd share/gccxml-0.6
36 patch -p3 <%{_sourcedir}/gccxml4
37
38
39 # SCRAM ToolBox toolfile
40 mkdir -p %i/etc/scram.d
41 cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
42 <doc type=BuildSystem::ToolDoc version=1.0>
43 <Tool name=%n version=%v>
44 <Client>
45 <Environment name=GCCXML_BASE default="%i"></Environment>
46 </Client>
47 <Runtime name=PATH value="$GCCXML_BASE/bin" type=path>
48 </Tool>
49 EOF_TOOLFILE
50
51 %post
52 %{relocateConfig}share/gccxml-%{gccxmlmajorver}/gccxml_config
53 %{relocateConfig}etc/scram.d/%n