ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcj.spec
Revision: 1.3
Committed: Sun Nov 12 12:13:55 2006 UTC (18 years, 5 months ago) by eulisse
Branch: MAIN
Changes since 1.2: +6 -3 lines
Log Message:
Non 3.2.3 version %if-ed out on 3.2.3.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external gcj 3.2.3
2     ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
4     ## BUILDIF [ $(uname) != Darwin ]
5     Source: ftp://ftp.fu-berlin.de/unix/gnu/gcc/gcc-%v/gcc-%v.tar.bz2
6    
7     %prep
8     %setup -n gcc-%v
9     %build
10     # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
11     # enabling it causes qt's uic to die with segmentation violation half
12     # way down the build of qt (projecsettings.ui or something like that;
13     # not the first or only call to uic). Disabling the flag removes the
14     # issue, so clearly the option does not work correctly on this
15     # platform combination.
16     mkdir -p obj
17     cd obj
18    
19     if [ "`echo %v | cut -d. -f 1`" == "3" ]
20     then
21     ../configure --prefix=%i --enable-languages=java \
22     --enable-shared # --enable-__cxa_atexit
23     else
24     ../configure --prefix=%i --enable-languages=java \
25     --enable-shared # --enable-__cxa_atexit
26     fi
27     make %makeprocesses bootstrap
28    
29     %install
30     cd obj && make install
31     ln -s gcc %i/bin/cc
32     %post
33 eulisse 1.2 # Required only by gcj > 3.4.5
34 eulisse 1.3 %if %v != 3.2.3
35     %{relocateConfig}lib/libffi.la
36     %{relocateConfig}lib/lib-org-w3c-dom.la
37     %{relocateConfig}lib/lib-org-xml-sax.la
38     %endif
39    
40 eulisse 1.1 %{relocateConfig}lib/libgcj.la
41     %{relocateConfig}lib/libstdc++.la
42     %{relocateConfig}lib/libsupc++.la