ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/gcj.spec
Revision: 1.5
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.4: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external gcj 3.2.3
2 ratnik 1.5 Requires: gcc-wrapper
3 eulisse 1.1 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/32
4     ## INITENV +PATH LD_LIBRARY_PATH %i/lib64
5     ## BUILDIF [ $(uname) != Darwin ]
6     Source: ftp://ftp.fu-berlin.de/unix/gnu/gcc/gcc-%v/gcc-%v.tar.bz2
7    
8     %prep
9     %setup -n gcc-%v
10     %build
11 ratnik 1.5 ## IMPORT gcc-wrapper
12 eulisse 1.1 # FIXME: --enable-__cxa_atexit can't be used with gcc 3.2.3 on RH 7.3,
13     # enabling it causes qt's uic to die with segmentation violation half
14     # way down the build of qt (projecsettings.ui or something like that;
15     # not the first or only call to uic). Disabling the flag removes the
16     # issue, so clearly the option does not work correctly on this
17     # platform combination.
18     mkdir -p obj
19     cd obj
20    
21     if [ "`echo %v | cut -d. -f 1`" == "3" ]
22     then
23     ../configure --prefix=%i --enable-languages=java \
24     --enable-shared # --enable-__cxa_atexit
25     else
26     ../configure --prefix=%i --enable-languages=java \
27     --enable-shared # --enable-__cxa_atexit
28     fi
29     make %makeprocesses bootstrap
30    
31     %install
32     cd obj && make install
33     ln -s gcc %i/bin/cc
34     %post
35 eulisse 1.4 %if "%v" != "3.2.3"
36 eulisse 1.3 %{relocateConfig}lib/libffi.la
37     %{relocateConfig}lib/lib-org-w3c-dom.la
38     %{relocateConfig}lib/lib-org-xml-sax.la
39     %endif
40    
41 eulisse 1.1 %{relocateConfig}lib/libgcj.la
42     %{relocateConfig}lib/libstdc++.la
43     %{relocateConfig}lib/libsupc++.la