Revision: | 1.3 |
Committed: | Tue May 23 17:26:52 2006 UTC (18 years, 11 months ago) by eulisse |
Branch: | MAIN |
CVS Tags: | CRABSERVER_TEST_BUILD_V4, CRABSERVER_TEST_BUILD_V3, CRABSERVER_TEST_BUILD_V2, CRABSERVER_TEST_BUILD_V1, forCRABSERVER104test, forCRABSERVER103, PRODAGENT_0_10_12_V10, PRODAGENT_0_10_12_V9, PRODAGENT_0_10_12_V8, PRODAGENT_0_10_12_V7, PRODAGENT_0_10_12_V6, PRODAGENT_0_10_12_V5, PRODAGENT_0_10_12_V4, forCS102pre4, PRODAGENT_0_10_12_V3, PRODAGENT_0_10_12_V2, PRODAGENT_0_10_12, PRODAGENT_0_10_3, PRODAGENT_0_10_3_20080521, PRODAGENT_0_8_3_SL4, forPA070pre3-slc3, forPA070pre3-slc4, forPA070pre3-slc, forPA061, forPA060pre7-slc4, forPA060pre3, forDBS106, forPA050pre3, WEBTOOLS_CONFIG_1_pre2, WEBTOOLS_CONFIG_1_pre1, forPA030, forPA020, PR_0_5_4, PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020, forPA011, forPR010, forPA010, for112, for111, cms143a-slc3, for120p5-slc3, for120p5slc4, for120p5slc3, forCMS143_2_rootfix, forCMS143_2_slc4, forCMS143_2_slc3, sfa061106pm, sfa061106am, sa20061106, sfa031106pm, sfa031106, sfa021106, sa20061002, for120p4, for120p3, for120p2-slc4-rc1, for120p2, for110, for120p1, for110p4, for110p3, af20060928, forGeant481, for110p2, CMSSW_1_0_0, for110p5, for110p1, for084, for100p4, argiro-20060904-for100p4, for092, for137a_pre083_take2, pe20060827a, for137a_pre083, ge20060825, for100p2, for100pre1, for091, for082, for090, CMSSW_0_8_1, for090_RC1, CMSSW_0_9_0_pre3, nr_baran081_t1, for080_testfixes1, for090p2, forCMSSW090p2, for080_testfixes, for090p2_RC5, for090p2_RC4, for090p2_RC3, for090p2_RC2, for090p2_RC1, ProdAgent_pa17, for081, for080_amd64, for080, for080p4, for080pre3, forLCG_44, forCMSSW_0_8_0_pre2, V00-01-02, V00-01-2, V00-01-01, V00-01-00, V00-00-11, V00-00-10, V00-00-09, V00-00-08 |
Branch point for: | lcg47branch |
Changes since 1.2: | +53 -0 lines |
Log Message: | -fixes build problem when passing -compiling_processes -first attempt for cmsglimpse (most likely not working, and anyway waiting for cmssw installation). |
# | User | Rev | Content |
---|---|---|---|
1 | elmer | 1.1 | ### RPM external glimpse 4.18.5 |
2 | Source: http://webglimpse.net/trial/glimpse-%{v}.tar.gz | ||
3 | |||
4 | %prep | ||
5 | %setup -n glimpse-%v | ||
6 | %build | ||
7 | ./configure --prefix=%{i} | ||
8 | eulisse | 1.2 | make |
9 | elmer | 1.1 | |
10 | %install | ||
11 | make install | ||
12 | eulisse | 1.3 | cat <<\EOF_CMS_GLIMPSE >%{instroot}/bin/cmsglimpse |
13 | #!/bin/bash | ||
14 | CURRENT_SCRAM_PROJECT=$(echo $SCRAMRT_SET | cut -d: -f2) | ||
15 | args= | ||
16 | action= | ||
17 | |||
18 | while [ $# -gt 0 ] | ||
19 | do | ||
20 | case $1 in | ||
21 | -index ) [ $# -gt 1 ] || { echo "Option \`$1' requires an argument" 1>&2; exit 1; } | ||
22 | action=index; shift;; | ||
23 | |||
24 | -help ) | ||
25 | echo "cmsglimpse [-H <CMSSW_TAG>] <search term>" | ||
26 | exit | ||
27 | ;; | ||
28 | -H )[ $# -gt 1 ] || { echo "Option \`$1' requires an argument" 1>&2; exit 1; } | ||
29 | CURRENT_SCRAM_PROJECT=$2; shift; shift ;; | ||
30 | * ) args="$args $1"; shift;; | ||
31 | esac | ||
32 | done | ||
33 | |||
34 | if [ "$CURRENT_SCRAM_PROJECT" == "" ] | ||
35 | then | ||
36 | echo "No project specified. " | ||
37 | echo "Please eval some scram runtime or use -H option." | ||
38 | exit 1 | ||
39 | fi | ||
40 | |||
41 | GLIMPSE_DIR=@INSTROOT@/share/glimpse/$CURRENT_SCRAM_PROJECT | ||
42 | |||
43 | if [ -d $GLIMPSE_DIR ] | ||
44 | then | ||
45 | echo "Glimpse index directory '$GLIMPSE_DIR' not found." | ||
46 | echo "Try running cmsglimpse -index" | ||
47 | exit 1 | ||
48 | fi | ||
49 | |||
50 | case $action in | ||
51 | index ) | ||
52 | (cd @INSTROOT@/@CMSPLATF@/cms/cmssw/$CURRENT_SCRAM_PROJECT; \ | ||
53 | eval `scramv1 run -sh`; | ||
54 | glimpseindex $args -H $CURRENT_SCRAM_PROJECT @INSTROOT@/@CMSPLATF@/cms/cmssw/$CURRENT_SCRAM_PROJECT;) | ||
55 | ;; | ||
56 | * ) | ||
57 | glimpse -H $CURRENT_SCRAM_PROJECT $args | ||
58 | ;; | ||
59 | esac | ||
60 | EOF_CMS_GLIMPSE | ||
61 | perl -p -i -e "s|\@CMSPLATF\@|%cmsplatf|g" %instroot/bin/cmsglimpse | ||
62 | chmod +x %{instroot}/bin/cmsglimpse | ||
63 | %post | ||
64 | perl -p -i -e "s|\@INSTROOT\@|$RPM_INSTALL_PREFIX|g" $RPM_INSTALL_PREFIX/bin/cmsglimpse |