ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/graphviz.spec
Revision: 1.10
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
CVS Tags: pe20070428a-ports, pe20070423b-ports, pe20070423a-ports
Changes since 1.9: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external graphviz 1.9
2 ratnik 1.10 Requires: gcc-wrapper
3 eulisse 1.1 Source: http://service-spi.web.cern.ch/service-spi/external/tarFiles/%{n}-%{v}.tar.gz
4 ratnik 1.4 Requires: expat zlib libjpg libpng
5 elmer 1.3 Patch0: graphviz
6 eulisse 1.1
7     %prep
8     %setup -n %{n}-%{v}
9 elmer 1.3 %patch0 -p1
10 eulisse 1.1
11     %build
12 ratnik 1.10 ## IMPORT gcc-wrapper
13 ratnik 1.4 ./configure \
14     --with-expatlibdir=$EXPAT_ROOT/lib \
15     --with-expatincludedir=$EXPAT_ROOT/include \
16     --with-zincludedir=$ZLIB_ROOT/include \
17     --with-zlibdir=$ZLIB_ROOT/lib \
18     --with-pngincludedir=$LIBJPG_ROOT/include \
19     --with-pnglibdir=$LIBJPG_ROOT/lib \
20     --with-jpegincludedir=$LIBPNG_ROOT/include \
21     --with-jpeglibdir=$LIBPNG_ROOT/lib \
22     --without-x \
23 elmer 1.9 --without-tclsh \
24 eulisse 1.5 --without-tcl \
25 argiro 1.6 --without-tk \
26 ratnik 1.4 --prefix=%{i}
27 elmer 1.8 # This is a workaround for the fact that sort from coreutils 5.96 doesn't
28     # like "sort +0 -1", not really something specific to ppc64/ydl5.0
29     if [ "$(uname -m)" == "ppc64" ]
30     then
31     perl -p -i -e "s|\+0 \-1|-k1,1|g" dotneato/common/Makefile
32     fi
33 eulisse 1.1 make
34 eulisse 1.7 %post
35     perl -p -i -e "s|%instroot|$RPM_INSTALL_PREFIX|" $RPM_INSTALL_PREFIX/%pkgrel/bin/dotneato-config `find $RPM_INSTALL_PREFIX/%pkgrel/lib/graphviz -name *.la`