1 |
elmer |
1.12 |
### RPM external graphviz 1.9-XXXX
|
2 |
|
|
Source: http://service-spi.web.cern.ch/service-spi/external/tarFiles/%{n}-%{realversion}.tar.gz
|
3 |
ratnik |
1.4 |
Requires: expat zlib libjpg libpng
|
4 |
elmer |
1.3 |
Patch0: graphviz
|
5 |
eulisse |
1.1 |
|
6 |
|
|
%prep
|
7 |
elmer |
1.12 |
%setup -n %{n}-%{realversion}
|
8 |
elmer |
1.3 |
%patch0 -p1
|
9 |
eulisse |
1.1 |
|
10 |
|
|
%build
|
11 |
ratnik |
1.4 |
./configure \
|
12 |
|
|
--with-expatlibdir=$EXPAT_ROOT/lib \
|
13 |
|
|
--with-expatincludedir=$EXPAT_ROOT/include \
|
14 |
|
|
--with-zincludedir=$ZLIB_ROOT/include \
|
15 |
|
|
--with-zlibdir=$ZLIB_ROOT/lib \
|
16 |
|
|
--with-pngincludedir=$LIBJPG_ROOT/include \
|
17 |
|
|
--with-pnglibdir=$LIBJPG_ROOT/lib \
|
18 |
|
|
--with-jpegincludedir=$LIBPNG_ROOT/include \
|
19 |
|
|
--with-jpeglibdir=$LIBPNG_ROOT/lib \
|
20 |
|
|
--without-x \
|
21 |
elmer |
1.9 |
--without-tclsh \
|
22 |
eulisse |
1.5 |
--without-tcl \
|
23 |
argiro |
1.6 |
--without-tk \
|
24 |
ratnik |
1.4 |
--prefix=%{i}
|
25 |
elmer |
1.8 |
# This is a workaround for the fact that sort from coreutils 5.96 doesn't
|
26 |
|
|
# like "sort +0 -1", not really something specific to ppc64/ydl5.0
|
27 |
|
|
if [ "$(uname -m)" == "ppc64" ]
|
28 |
|
|
then
|
29 |
|
|
perl -p -i -e "s|\+0 \-1|-k1,1|g" dotneato/common/Makefile
|
30 |
|
|
fi
|
31 |
eulisse |
1.1 |
make
|
32 |
eulisse |
1.7 |
%post
|
33 |
|
|
perl -p -i -e "s|%instroot|$RPM_INSTALL_PREFIX|" $RPM_INSTALL_PREFIX/%pkgrel/bin/dotneato-config `find $RPM_INSTALL_PREFIX/%pkgrel/lib/graphviz -name *.la`
|