ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/graphviz.spec
Revision: 1.17
Committed: Sat Jan 19 18:46:58 2008 UTC (17 years, 3 months ago) by elmer
Branch: MAIN
CVS Tags: pe20080120a-ports-412, pe20080120a-ports
Changes since 1.16: +11 -5 lines
Log Message:
Update to graphviz version 2.16.1(-CMS19). Previously this was 1.9, but
it did not build on MacOSX. As part of this remove the graphviz.patch as
I believe it is no longer needed (I think I originally backported that
to 1.9 from some more recent version) and fix the relocations so that
they do all of the .la's (these are in both "lib/" and "lib/graphviz"
in the new version). bin/dotneato-config no longer seems to exist
so drop that relocation. For Darwin a small fix to configure was necessary.

File Contents

# User Rev Content
1 elmer 1.17 ### RPM external graphviz 2.16.1-CMS19
2     Source: http://www.graphviz.org/pub/%{n}/ARCHIVE/%{n}-%{realversion}.tar.gz
3 ratnik 1.4 Requires: expat zlib libjpg libpng
4 eulisse 1.1
5     %prep
6 elmer 1.12 %setup -n %{n}-%{realversion}
7 eulisse 1.1
8     %build
9 ratnik 1.4 ./configure \
10     --with-expatlibdir=$EXPAT_ROOT/lib \
11     --with-expatincludedir=$EXPAT_ROOT/include \
12     --with-zincludedir=$ZLIB_ROOT/include \
13     --with-zlibdir=$ZLIB_ROOT/lib \
14     --with-pngincludedir=$LIBJPG_ROOT/include \
15     --with-pnglibdir=$LIBJPG_ROOT/lib \
16     --with-jpegincludedir=$LIBPNG_ROOT/include \
17     --with-jpeglibdir=$LIBPNG_ROOT/lib \
18     --without-x \
19 elmer 1.9 --without-tclsh \
20 eulisse 1.5 --without-tcl \
21 argiro 1.6 --without-tk \
22 ratnik 1.4 --prefix=%{i}
23 elmer 1.8 # This is a workaround for the fact that sort from coreutils 5.96 doesn't
24     # like "sort +0 -1", not really something specific to ppc64/ydl5.0
25     if [ "$(uname -m)" == "ppc64" ]
26     then
27     perl -p -i -e "s|\+0 \-1|-k1,1|g" dotneato/common/Makefile
28     fi
29 elmer 1.17 # Probably the configure should just be remade on Darwin, but it builds
30     # as-is with this small cleanup
31     %ifos darwin
32     perl -p -i -e "s|-lexpat||g" configure
33     %endif
34 eulisse 1.1 make
35 muzaffar 1.14
36     %install
37     make install
38     # SCRAM ToolBox toolfile
39     mkdir -p %i/etc/scram.d
40     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
41     <doc type=BuildSystem::ToolDoc version=1.0>
42     <Tool name=%n version=%v>
43     <info url="http://www.research.att.com/sw/tools/graphviz/"></info>
44     <Client>
45     <Environment name=GRAPHVIZ_BASE default="%i"></Environment>
46     <Environment name=GRAPHVIZ_BINDIR default="$GRAPHVIZ_BASE/bin"></Environment>
47     <Environment name=LIBDIR default="$GRAPHVIZ_BASE/lib/graphviz"></Environment>
48     </Client>
49     <Runtime name=PATH value="$GRAPHVIZ_BINDIR" type=path>
50     <Use name=expat>
51     <Use name=zlib>
52     <Use name=libjpg>
53     <use name=libpng>
54     </Tool>
55     EOF_TOOLFILE
56    
57 eulisse 1.7 %post
58 elmer 1.17 # It appears one needs to list at least one explicitly as the macro adds
59     # the prefix, but then the find can add it and the others (also with the
60     # prefix)
61     %{relocateConfig}/lib/libgraph.la `find $RPM_INSTALL_PREFIX/%pkgrel/lib -name *.la`
62 muzaffar 1.14 %{relocateConfig}etc/scram.d/%n