ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/graphviz.spec
Revision: 1.8
Committed: Sat Mar 31 01:19:58 2007 UTC (18 years, 1 month ago) by elmer
Branch: MAIN
CVS Tags: pe20070409a-ports, pe20070407a-ports, pe20070407-ports
Changes since 1.7: +6 -1 lines
Log Message:
Workaround for coreutils 5.96 doesn't like "sort +0 -1" (on ppc64, though
not really something specific to ppc64/ydl5.0)

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external graphviz 1.9
2     Source: http://service-spi.web.cern.ch/service-spi/external/tarFiles/%{n}-%{v}.tar.gz
3 ratnik 1.4 Requires: expat zlib libjpg libpng
4 elmer 1.3 Patch0: graphviz
5 eulisse 1.1
6     %prep
7     %setup -n %{n}-%{v}
8 elmer 1.3 %patch0 -p1
9 eulisse 1.1
10     %build
11 ratnik 1.4 ./configure \
12     --with-expatlibdir=$EXPAT_ROOT/lib \
13     --with-expatincludedir=$EXPAT_ROOT/include \
14     --with-zincludedir=$ZLIB_ROOT/include \
15     --with-zlibdir=$ZLIB_ROOT/lib \
16     --with-pngincludedir=$LIBJPG_ROOT/include \
17     --with-pnglibdir=$LIBJPG_ROOT/lib \
18     --with-jpegincludedir=$LIBPNG_ROOT/include \
19     --with-jpeglibdir=$LIBPNG_ROOT/lib \
20     --without-x \
21 eulisse 1.5 --without-tcl \
22 argiro 1.6 --without-tk \
23 ratnik 1.4 --prefix=%{i}
24 elmer 1.8 # This is a workaround for the fact that sort from coreutils 5.96 doesn't
25     # like "sort +0 -1", not really something specific to ppc64/ydl5.0
26     if [ "$(uname -m)" == "ppc64" ]
27     then
28     perl -p -i -e "s|\+0 \-1|-k1,1|g" dotneato/common/Makefile
29     fi
30 eulisse 1.1 make
31 eulisse 1.7 %post
32     perl -p -i -e "s|%instroot|$RPM_INSTALL_PREFIX|" $RPM_INSTALL_PREFIX/%pkgrel/bin/dotneato-config `find $RPM_INSTALL_PREFIX/%pkgrel/lib/graphviz -name *.la`