ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/graphviz.spec
Revision: 1.14
Committed: Mon Sep 3 15:28:45 2007 UTC (17 years, 8 months ago) by muzaffar
Branch: MAIN
CVS Tags: CMSSW_1_7_7, dl080227for176, CMSSW_1_7_5_ONLINE1, CMSSW_1_7_5, CMSSW_1_7_5_g491, CMSSW_1_7_5_ONLINE, nr080115onl175, dl080111, ge20080109-webconddb, ge20080109-sitedb, CMSSW_1_7_4, CMSSW_1_7_3_g490p1, dl071212t2, dl071212, CMSSW_1_7_3, CMSSW_1_7_2, CMSSW_1_7_1, nr071121onl170_xdaq5, nr071120_fwlite170_1, CMSSW_1_7_0_ONLINE, CMSSW_1_7_0, nr071116onlpre13, CMSSW_1_7_0_pre13, dl071114, ap20071113, CMSSW_1_7_0_pre12, CMSSW_1_7_0_pre10_ONLINE, CMSSW_1_7_0_pre11, nr071105a, pe20071102a-ports, CMSSW_1_7_0_pre10, CMSSW_1_7_0_pre9, CMSSW_1_7_0_pre8, CMSSW_1_7_0_pre7, dl071028, dl071024, nr071023_fwlite170p6, pe20071023-170p6-amd64, forTony_001, pe20071021-170p6-zlib, dl071021t2, dl071021, pe20071021a-ports, dl071020, nr071017_170p5onl2, CMSSW_1_7_0_pre6, nr071016_170p5onl1, nr071016onl170p5bs, nr071016onl170p5, pe20071015-xrootd, pe20071014-ports, dl071014, dl071010t2, dl071010, dl071009t2, dl071009, CMSSW_1_7_0_pre5, dl070926t2, dl070926, ap-20070926, CMSSW_1_7_0_pre4, dl070921t2, dl070921, dl070920, CMSSW_1_7_0_pre3, dl070916, dl070912, dl070812, sm070912b, sm070912a, sm070911a, dl070909p3, dl070909, CMSSW_1_7_0_pre2, dl070906, dl070905, sm030907a
Changes since 1.13: +25 -2 lines
Log Message:
new spec files for auto generation of toolfile i.e. no need of scramtoolbox

File Contents

# Content
1 ### RPM external graphviz 1.9-CMS8
2 Source: http://service-spi.web.cern.ch/service-spi/external/tarFiles/%{n}-%{realversion}.tar.gz
3 Requires: expat zlib libjpg libpng
4 Patch0: graphviz
5
6 %prep
7 %setup -n %{n}-%{realversion}
8 %patch0 -p1
9
10 %build
11 ./configure \
12 --with-expatlibdir=$EXPAT_ROOT/lib \
13 --with-expatincludedir=$EXPAT_ROOT/include \
14 --with-zincludedir=$ZLIB_ROOT/include \
15 --with-zlibdir=$ZLIB_ROOT/lib \
16 --with-pngincludedir=$LIBJPG_ROOT/include \
17 --with-pnglibdir=$LIBJPG_ROOT/lib \
18 --with-jpegincludedir=$LIBPNG_ROOT/include \
19 --with-jpeglibdir=$LIBPNG_ROOT/lib \
20 --without-x \
21 --without-tclsh \
22 --without-tcl \
23 --without-tk \
24 --prefix=%{i}
25 # This is a workaround for the fact that sort from coreutils 5.96 doesn't
26 # like "sort +0 -1", not really something specific to ppc64/ydl5.0
27 if [ "$(uname -m)" == "ppc64" ]
28 then
29 perl -p -i -e "s|\+0 \-1|-k1,1|g" dotneato/common/Makefile
30 fi
31 make
32
33 %install
34 make install
35 # SCRAM ToolBox toolfile
36 mkdir -p %i/etc/scram.d
37 cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
38 <doc type=BuildSystem::ToolDoc version=1.0>
39 <Tool name=%n version=%v>
40 <info url="http://www.research.att.com/sw/tools/graphviz/"></info>
41 <Client>
42 <Environment name=GRAPHVIZ_BASE default="%i"></Environment>
43 <Environment name=GRAPHVIZ_BINDIR default="$GRAPHVIZ_BASE/bin"></Environment>
44 <Environment name=LIBDIR default="$GRAPHVIZ_BASE/lib/graphviz"></Environment>
45 </Client>
46 <Runtime name=PATH value="$GRAPHVIZ_BINDIR" type=path>
47 <Use name=expat>
48 <Use name=zlib>
49 <Use name=libjpg>
50 <use name=libpng>
51 </Tool>
52 EOF_TOOLFILE
53
54 %post
55 %{relocateConfig}bin/dotneato-config `find $RPM_INSTALL_PREFIX/%pkgrel/lib/graphviz -name *.la`
56 %{relocateConfig}etc/scram.d/%n