ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/graphviz.spec
Revision: 1.4
Committed: Fri Aug 4 16:32:55 2006 UTC (18 years, 9 months ago) by ratnik
Branch: MAIN
CVS Tags: for082, for090, CMSSW_0_8_1, for090_RC1, CMSSW_0_9_0_pre3, for080_testfixes1
Changes since 1.3: +13 -2 lines
Log Message:
Added explicit dependency to required z, jpeg and png libraries, and made sure graphviz build will pick them from our installation

File Contents

# Content
1 ### RPM external graphviz 1.9
2 Source: http://service-spi.web.cern.ch/service-spi/external/tarFiles/%{n}-%{v}.tar.gz
3 Requires: expat zlib libjpg libpng
4 Patch0: graphviz
5
6 %prep
7 %setup -n %{n}-%{v}
8 %patch0 -p1
9
10 %build
11 ./configure \
12 --with-expatlibdir=$EXPAT_ROOT/lib \
13 --with-expatincludedir=$EXPAT_ROOT/include \
14 --with-zincludedir=$ZLIB_ROOT/include \
15 --with-zlibdir=$ZLIB_ROOT/lib \
16 --with-pngincludedir=$LIBJPG_ROOT/include \
17 --with-pnglibdir=$LIBJPG_ROOT/lib \
18 --with-jpegincludedir=$LIBPNG_ROOT/include \
19 --with-jpeglibdir=$LIBPNG_ROOT/lib \
20 --without-x \
21 --prefix=%{i}
22
23 make