1 |
eulisse |
1.33 |
### RPM cms iguana IGUANA_6_12_2-withGeant481p2CMS
|
2 |
eulisse |
1.9 |
## IMPORT configurations
|
3 |
eulisse |
1.12 |
Requires: iguana-tool-conf python cms-env
|
4 |
argiro |
1.27 |
Patch: iguana-config-gcc345-fix
|
5 |
|
|
|
6 |
|
|
%define patchsrc perl -p -i -e 's|.*ignominy.*||' config/requirements
|
7 |
|
|
%define patchsrc2 perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' $(grep -r -e "^#\!.*perl.*" . | cut -d: -f1)
|
8 |
|
|
%define patchsrc3 rm -rf %srctree/VisExamples/VisG4ExAtlas; rm -rf %srctree/Ig_Modules/IgQtProfileService/test/
|
9 |
|
|
%define patchsrc4 %%patch0
|
10 |
|
|
|
11 |
|
|
|
12 |
eulisse |
1.1 |
%define toolconf ${IGUANA_TOOL_CONF_ROOT}/configurations/tools-STANDALONE.conf
|
13 |
argiro |
1.29 |
%define cvsdir iguana
|
14 |
eulisse |
1.16 |
%define cvsserver iguana
|
15 |
eulisse |
1.1 |
%define srctree1 VisGeant4
|
16 |
eulisse |
1.16 |
%define realTag %(echo %v | cut -d- -f1)
|
17 |
argiro |
1.29 |
%define additionalSrc0 cvs://:pserver:anonymous@isscvs.cern.ch:/local/reps/iguanacms?passwd=AA_:yZZ3e&tag=-r%{realTag}&module=VisGeant4&export=%{srctree1}
|
18 |
|
|
|
19 |
eulisse |
1.1 |
|
20 |
eulisse |
1.2 |
%define srctree2 VisExamples
|
21 |
argiro |
1.29 |
%define additionalSrc1 cvs://:pserver:anonymous@isscvs.cern.ch:/local/reps/iguanacms?passwd=AA_:yZZ3e&tag=-r%{realTag}&module=VisExamples&export=%{srctree2}
|
22 |
|
|
|
23 |
|
|
|
24 |
|
|
# here cut and paste cms-scram-build.file
|
25 |
|
|
# I need to modify the cvs repo, since iguana has been migrated to IT (SA, 060904)
|
26 |
|
|
|
27 |
|
|
%define cvsproj %(echo %n | sed -e "s|-debug||"| tr 'a-z' 'A-Z')
|
28 |
|
|
%define cvsrepo cvs://:pserver:anonymous@isscvs.cern.ch:/local/reps/%cvsdir?passwd=AA_:yZZ3e
|
29 |
|
|
%define cvstag %(echo %v | cut -d- -f1)
|
30 |
|
|
%if "%{?cvsconfig:set}" != "set"
|
31 |
|
|
%define cvsconfig config
|
32 |
|
|
%endif
|
33 |
|
|
%define cvssrc %cvsproj
|
34 |
|
|
%define srctree src
|
35 |
|
|
|
36 |
|
|
%define tbxrepo cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/SCRAMToolBox?passwd=AA_:yZZ3e
|
37 |
|
|
%define conftag CMS_%confversion%conflevel
|
38 |
|
|
%define confsite CMSconfigs
|
39 |
|
|
|
40 |
|
|
%if "%{buildarch:set}" != "set"
|
41 |
|
|
%define buildarch :
|
42 |
|
|
%endif
|
43 |
|
|
|
44 |
|
|
%if "%{?buildtarget:set}" != "set"
|
45 |
|
|
%define buildtarget %{nil}
|
46 |
|
|
%endif
|
47 |
|
|
|
48 |
|
|
# end cut and paste
|
49 |
|
|
|
50 |
eulisse |
1.2 |
|
51 |
eulisse |
1.1 |
## IMPORT scramv1-build
|
52 |
|
|
|
53 |
eulisse |
1.9 |
%define confversion %cmsConfiguration
|
54 |
eulisse |
1.1 |
%define conflevel _1
|
55 |
eulisse |
1.12 |
|