ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/java-jdk.spec
Revision: 1.11
Committed: Mon Sep 3 15:28:45 2007 UTC (17 years, 7 months ago) by muzaffar
Branch: MAIN
CVS Tags: dl070905, sm030907a
Changes since 1.10: +40 -22 lines
Log Message:
new spec files for auto generation of toolfile i.e. no need of scramtoolbox

File Contents

# User Rev Content
1 muzaffar 1.11 ### RPM external java-jdk 1.5.0.p6
2     ## BUILDIF [ "$(uname)" != "Darwin" ]
3    
4     Provides: libasound.so.2
5     Provides: libasound.so.2(ALSA_0.9)
6     Provides: libjava_crw_demo_g.so
7     Provides: libodbc.so
8     Provides: libodbcinst.so
9    
10     %define downloadv %(echo %v | tr '.p' '_0')
11    
12     %define tmpArch %(echo %cmsplatf | cut -d_ -f 1,2)
13    
14     %if "%{tmpArch}" == "slc3_ia32"
15     %define downloadarch i586
16     %endif
17    
18     # A hack? Probably won't work for slc4 but...
19     %if "%{tmpArch}" == "slc4_ia32"
20     %define downloadarch i586
21     %endif
22    
23     %if "%{tmpArch}" == "slc3_amd64"
24     %define downloadarch amd64
25     %endif
26    
27     Source0: http://eulisse.web.cern.ch/eulisse/jdk-%downloadv-linux-i586.bin
28     Source1: http://eulisse.web.cern.ch/eulisse/jdk-%downloadv-linux-amd64.bin
29    
30 eulisse 1.1 %prep
31 muzaffar 1.11 %if %(uname) != Darwin
32     ls
33     %define javadir jdk%(echo %v| sed -e "s/.p/_0/")
34     rm -rf %javadir
35     yes | sh %{_sourcedir}/jdk-%downloadv-linux-%downloadarch.bin
36     cd %javadir
37     %endif
38 eulisse 1.1 %build
39     %install
40 muzaffar 1.11 %if %(uname) != Darwin
41     ls
42     cp -r %javadir/* %i
43     %endif