ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/java-jdk.spec
Revision: 1.17
Committed: Tue Feb 10 03:39:03 2009 UTC (16 years, 2 months ago) by valya
Branch: MAIN
CVS Tags: DBS-APPS_20090220, MEMCACHED_20090219_1, MEMCACHED_20090219, WEBTOOLS-APPS_20090217_1, WEBTOOLS-APPS_20090217, WEBTOOLS-APPS_20090216, WEBTOOLS-APPS_20090212, WEBTOOLS-APPS_20090209_64bit
Changes since 1.16: +9 -3 lines
Log Message:
Added for java-jdk 64-bit libs

File Contents

# User Rev Content
1 valya 1.15 ### RPM external java-jdk 1.5.0_15
2 muzaffar 1.11 ## BUILDIF [ "$(uname)" != "Darwin" ]
3    
4     Provides: libasound.so.2
5 valya 1.17 Provides: libasound.so.2(ALSA_0.9)
6     Provides: libjava_crw_demo_g.so()
7     Provides: libodbc.so
8 muzaffar 1.11 Provides: libodbcinst.so
9 valya 1.17 # 64 bit versions
10     Provides: libasound.so.2()(64bit)
11     Provides: libasound.so.2(ALSA_0.9)(64bit)
12     Provides: libjava_crw_demo_g.so()(64bit)
13     Provides: libodbc.so()(64bit)
14     Provides: libodbcinst.so()(64bit)
15 muzaffar 1.11
16 dlange 1.12 %define downloadv %(echo %realversion | tr '.p' '_0')
17 muzaffar 1.11
18     %define tmpArch %(echo %cmsplatf | cut -d_ -f 1,2)
19    
20     %if "%{tmpArch}" == "slc3_ia32"
21     %define downloadarch i586
22     %endif
23    
24     # A hack? Probably won't work for slc4 but...
25     %if "%{tmpArch}" == "slc4_ia32"
26     %define downloadarch i586
27     %endif
28    
29     %if "%{tmpArch}" == "slc3_amd64"
30     %define downloadarch amd64
31     %endif
32    
33 valya 1.16 %if "%{tmpArch}" == "slc4_amd64"
34     %define downloadarch amd64
35     %endif
36    
37 valya 1.15 Source0: http://cmsrep.cern.ch/cmssw/jdk-mirror/jdk-%downloadv-linux-i586.bin
38     Source1: http://cmsrep.cern.ch/cmssw/jdk-mirror/jdk-%downloadv-linux-amd64.bin
39 muzaffar 1.11
40 eulisse 1.1 %prep
41 muzaffar 1.11 %if %(uname) != Darwin
42     ls
43 dlange 1.13 %define javadir jdk%(echo %realversion| sed -e "s/.p/_0/")
44 muzaffar 1.11 rm -rf %javadir
45     yes | sh %{_sourcedir}/jdk-%downloadv-linux-%downloadarch.bin
46     cd %javadir
47     %endif
48 eulisse 1.1 %build
49     %install
50 muzaffar 1.11 %if %(uname) != Darwin
51     ls
52     cp -r %javadir/* %i
53     %endif