ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/java-jdk.spec
Revision: 1.4
Committed: Thu Jun 15 13:19:35 2006 UTC (18 years, 10 months ago) by eulisse
Branch: MAIN
CVS Tags: forLCG_44, forCMSSW_0_8_0_pre2, V00-01-02, V00-01-2, V00-01-01, V00-01-00
Changes since 1.3: +7 -0 lines
Log Message:
Faking dependecies on alsa

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external java-jdk 1.5.0.p6
2     ## BUILDIF [ $(uname) != Darwin ]
3 eulisse 1.4
4     Provides: libasound.so.2
5     Provides: libasound.so.2(ALSA_0.9)
6     Provides: libjava_crw_demo_g.so
7     Provides: libodbc.so
8     Provides: libodbcinst.so
9    
10 eulisse 1.1 %define downloadv %(echo %v | tr '.p' '_0')
11 eulisse 1.2
12 eulisse 1.3 %define tmpArch %(echo %cmsplatf | cut -d_ -f 1,2)
13    
14     %if "%{tmpArch}" == "slc3_ia32"
15 eulisse 1.2 %define downloadarch i586
16     %endif
17    
18 eulisse 1.3 %if "%{tmpArch}" == "slc3_amd64"
19 eulisse 1.2 %define downloadarch amd64
20     %endif
21    
22     %if "%{?downloadarch:set}" != "set"
23     %error Unsupported architecture.
24     %endif
25    
26     Source: http://eulisse.web.cern.ch/eulisse/jdk-%downloadv-linux-%downloadarch.bin
27 eulisse 1.1 %prep
28     ls
29     %define javadir jdk%(echo %v| sed -e "s/.p/_0/")
30     rm -rf %javadir
31 eulisse 1.2 yes | sh %{_sourcedir}/jdk-%downloadv-linux-%downloadarch.bin
32 eulisse 1.1 cd %javadir
33     %build
34     %install
35     ls
36     cp -r %javadir/* %i