1 |
muzaffar |
1.1 |
### RPM external kcachegrind 0.4.6-cmsp1
|
2 |
|
|
Provides: libDCOP.so.4
|
3 |
|
|
Provides: libart_lgpl_2.so.2
|
4 |
|
|
Provides: libfam.so.0
|
5 |
|
|
Provides: libkdecore.so.4
|
6 |
|
|
Provides: libkdefx.so.4
|
7 |
|
|
Provides: libkdesu.so.4
|
8 |
|
|
Provides: libkdeui.so.4
|
9 |
|
|
Provides: libkio.so.4
|
10 |
|
|
Provides: libkwalletclient.so.1
|
11 |
|
|
Requires: qt libpng libjpg zlib
|
12 |
|
|
|
13 |
|
|
%define realversion %(echo %v | cut -d- -f1)
|
14 |
|
|
%define machine_os %(echo %cmsplatf | cut -d_ -f1)
|
15 |
|
|
%if "%{machine_os}" == "slc4"
|
16 |
|
|
%define sourcefile0 http://kcachegrind.sourceforge.net/%{n}-%{realversion}.tar.gz
|
17 |
|
|
%define pacthfile0 http://cmsdoc.cern.ch/~muzaffar/public/%{n}-%{realversion}-patch.tar.gz
|
18 |
|
|
%else
|
19 |
|
|
%define sourcefile0 none
|
20 |
|
|
%define pacthfile0 none
|
21 |
|
|
%endif
|
22 |
|
|
|
23 |
|
|
Source0: %sourcefile0
|
24 |
|
|
Source1: %pacthfile0
|
25 |
|
|
|
26 |
|
|
%prep
|
27 |
|
|
%if "%{machine_os}" == "slc4"
|
28 |
|
|
%setup -T -b 1 -n %{n}-%{realversion}-patch
|
29 |
|
|
%setup -T -b 0 -n %{n}-%{realversion}
|
30 |
|
|
# CMS patch
|
31 |
|
|
cp -fp %{_builddir}/%{n}-%{realversion}-patch/functionnameanalyzer.* %{_builddir}/%n-%realversion/kcachegrind/
|
32 |
|
|
patch -u %{_builddir}/%n-%realversion/kcachegrind/tracedata.cpp %{_builddir}/%{n}-%{realversion}-patch/tracedata.cpp.patch
|
33 |
|
|
patch -u %{_builddir}/%n-%realversion/kcachegrind/Makefile.am %{_builddir}/%{n}-%{realversion}-patch/Makefile.am.patch
|
34 |
|
|
make -f admin/Makefile.common cvs
|
35 |
|
|
%endif
|
36 |
|
|
|
37 |
|
|
%build
|
38 |
|
|
%if "%{machine_os}" == "slc4"
|
39 |
|
|
export CPPFLAGS="-I$LIBPNG_ROOT/include -I$LIBJPG_ROOT/include -I$ZLIB_ROOT/include"
|
40 |
|
|
export LDFLAGS="-L$LIBPNG_ROOT/lib -L$LIBJPG_ROOT/lib -L$ZLIB_ROOT/lib"
|
41 |
|
|
./configure --prefix=%i
|
42 |
|
|
make %makeprocesses
|
43 |
|
|
%install
|
44 |
|
|
make install
|
45 |
|
|
%endif
|
46 |
|
|
%post
|
47 |
|
|
%if "%{machine_os}" != "slc4"
|
48 |
|
|
mkdir -p $RPM_INSTALL_PREFIX/%pkgrel/bin
|
49 |
|
|
cat << \EOF_KCACHEGRIND > $RPM_INSTALL_PREFIX/%pkgrel/bin/kcachegrind
|
50 |
|
|
#!/bin/sh
|
51 |
|
|
echo "WARNING: KCachegrind is only available for %{machine_os}"
|
52 |
|
|
EOF_KCACHEGRIND
|
53 |
|
|
chmod 755 $RPM_INSTALL_PREFIX/%pkgrel/bin/kcachegrind
|
54 |
|
|
%endif
|