ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/kcachegrind.spec
Revision: 1.2
Committed: Tue Feb 20 12:57:14 2007 UTC (18 years, 2 months ago) by muzaffar
Branch: MAIN
Changes since 1.1: +12 -11 lines
Log Message:
fixed kcachegrind spec to not add hardcoded path in the executable

File Contents

# User Rev Content
1 muzaffar 1.1 ### RPM external kcachegrind 0.4.6-cmsp1
2     Provides: libDCOP.so.4
3     Provides: libart_lgpl_2.so.2
4     Provides: libfam.so.0
5     Provides: libkdecore.so.4
6     Provides: libkdefx.so.4
7     Provides: libkdesu.so.4
8     Provides: libkdeui.so.4
9     Provides: libkio.so.4
10     Provides: libkwalletclient.so.1
11 muzaffar 1.2 Requires: qt libpng
12 muzaffar 1.1
13     %define realversion %(echo %v | cut -d- -f1)
14     %define machine_os %(echo %cmsplatf | cut -d_ -f1)
15     %if "%{machine_os}" == "slc4"
16     %define sourcefile0 http://kcachegrind.sourceforge.net/%{n}-%{realversion}.tar.gz
17 muzaffar 1.2 %define pacthfile0 http://cmsdoc.cern.ch/~muzaffar/public/%{n}-%{realversion}-patch1.tar.gz
18 muzaffar 1.1 %else
19 muzaffar 1.2 %define sourcefile0 none
20     %define pacthfile0 none
21 muzaffar 1.1 %endif
22    
23     Source0: %sourcefile0
24     Source1: %pacthfile0
25    
26     %prep
27     %if "%{machine_os}" == "slc4"
28 muzaffar 1.2 %setup -T -b 1 -n %{n}-%{realversion}-patch1
29 muzaffar 1.1 %setup -T -b 0 -n %{n}-%{realversion}
30     # CMS patch
31 muzaffar 1.2 cp -fp %{_builddir}/%{n}-%{realversion}-patch1/functionnameanalyzer.* %{_builddir}/%n-%realversion/kcachegrind/
32     patch -u %{_builddir}/%n-%realversion/kcachegrind/tracedata.cpp %{_builddir}/%{n}-%{realversion}-patch1/tracedata.cpp.patch
33     patch -u %{_builddir}/%n-%realversion/kcachegrind/Makefile.am %{_builddir}/%{n}-%{realversion}-patch1/Makefile.am.patch
34 muzaffar 1.1 make -f admin/Makefile.common cvs
35     %endif
36    
37     %build
38     %if "%{machine_os}" == "slc4"
39 muzaffar 1.2 export CPPFLAGS="-I$LIBPNG_ROOT/include"
40     export LDFLAGS="-L$LIBPNG_ROOT/lib"
41     ./configure --prefix=%i --disable-rpath
42     patch -u %{_builddir}/%n-%realversion/libtool %{_builddir}/%{n}-%{realversion}-patch1/libtool.patch
43 muzaffar 1.1 make %makeprocesses
44     %install
45     make install
46     %endif
47     %post
48     %if "%{machine_os}" != "slc4"
49     mkdir -p $RPM_INSTALL_PREFIX/%pkgrel/bin
50     cat << \EOF_KCACHEGRIND > $RPM_INSTALL_PREFIX/%pkgrel/bin/kcachegrind
51     #!/bin/sh
52     echo "WARNING: KCachegrind is only available for %{machine_os}"
53     EOF_KCACHEGRIND
54     chmod 755 $RPM_INSTALL_PREFIX/%pkgrel/bin/kcachegrind
55     %endif