ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/lhapdf.spec
Revision: 1.10
Committed: Tue Oct 23 18:10:38 2007 UTC (17 years, 6 months ago) by elmer
Branch: MAIN
Changes since 1.9: +5 -0 lines
Log Message:
Various gfortran patches for the crappy generators, conditional on
an slc4_ia32_gcc412 build for the moment. Nothing is guaranteed
for them at this point, except that they build. (Actually tauola
doesn't even do that yet.)

File Contents

# User Rev Content
1 muzaffar 1.9 ### RPM external lhapdf 5.2.3-CMS8
2 ratnik 1.2 %define realversion %(echo %v | cut -d- -f1)
3     Source: http://cern.ch/service-spi/external/MCGenerators/distribution/%{n}-%{realversion}-src.tgz
4 ratnik 1.1 %prep
5 ratnik 1.2 %setup -q -n %{n}/%{realversion}
6 elmer 1.10 %if "%cmsplatf" == "slc4_ia32_gcc412"
7     # Switch to gfortran
8     perl -p -i -e 's|^export F77\=g77|export F77=gfortran|' .scripts/platform_functions
9     perl -p -i -e 's| -Wno-globals||' configure
10     %endif
11 ratnik 1.1 ./configure
12    
13     %build
14     make
15    
16     %install
17 ratnik 1.2 tar -c lib include PDFsets | tar -x -C %i
18 muzaffar 1.9 # SCRAM ToolBox toolfile
19     mkdir -p %i/etc/scram.d
20     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
21     <doc type=BuildSystem::ToolDoc version=1.0>
22     <Tool name=lhapdf version=%v>
23     <lib name=lhapdf>
24     <lib name=lhapdf_dummy>
25     <Client>
26     <Environment name=LHAPDF_BASE default="%i"></Environment>
27     <Environment name=LIBDIR default="$LHAPDF_BASE/lib"></Environment>
28     <Environment name=INCLUDE default="$LHAPDF_BASE/include"></Environment>
29     <Environment name=LHAPATH default="$LHAPDF_BASE/PDFsets"></Environment>
30     </Client>
31     <Runtime name=LHAPATH value="$LHAPDF_BASE/PDFsets" type=path>
32     <use name=f77compiler>
33     </Tool>
34     EOF_TOOLFILE
35    
36     %post
37     %{relocateConfig}etc/scram.d/%n