ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/libjio.spec
Revision: 1.3
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
CVS Tags: pe20070428a-ports, pe20070423b-ports, pe20070423a-ports
Changes since 1.2: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 steen 1.1 ### RPM external libjio 0.22
2 ratnik 1.3 Requires: gcc-wrapper
3 steen 1.2
4     ## INITENV +PATH LD_LIBRARY_PATH %{i}/lib
5    
6 steen 1.1 # package information
7     Summary: Journalled IO Library
8     URL: http://users.auriga.wearlab.de/~alb/libjio/
9     Vendor: Alberto Bertogli <albertogli@telpin.com.ar>
10     Packager: Conrad Steenberg <conrad@hep.caltech.edu>
11    
12     # list of sources
13     Source: http://users.auriga.wearlab.de/~alb/libjio/files/%{v}/%{n}-%{v}.tar.bz2
14    
15     # build information
16     Requires: gcc
17    
18     %description
19     Libjio is a userspace library to do journaled, transaction-oriented I/O.
20    
21     It provides a very simple API to commit and rollback transactions, and on
22     top of that a UNIX-alike set of functions to perform most regular operations
23     (ie. open(), read(), write()) in a non-intrusive threadsafe and atomic way,
24     with safe and fast crash recovery. This allows the library to guarantee file
25     integrity even after unexpected crashes, never leaving your files in an
26     inconsistent state. On the disk, the file you work on is exactly like a
27     regular one, but a special directory is created to store in-flight
28     transactions.
29    
30 steen 1.2 %prep
31     %setup -n %n-%v
32    
33 steen 1.1 %build
34 ratnik 1.3 ## IMPORT gcc-wrapper
35 steen 1.1 make
36    
37     %install
38     # rm -rf %i
39    
40     mkdir -p -m 755 \
41     %i/lib
42    
43     mkdir -p -m 755 \
44     %i/bin
45    
46     mkdir -p -m 755 \
47     %i/include
48    
49     mkdir -p -m 755 \
50     %i/doc/libjio-%{v}
51    
52     #ansi.c check.o common.h jiofsck libjio.h README unix.c
53     #ansi.o checksum.c common.o jiofsck.c libjio.so samples unix.o
54     #bindings checksum.o doc jiofsck.o Make.conf trans.c UPGRADING
55     #check.c common.c INSTALL libjio.a Makefile trans.o utils
56    
57     install -m 755 \
58     jiofsck \
59     %i/bin
60    
61    
62     install -m 644 \
63     libjio.h \
64     %i/include
65    
66    
67     install -m 644 \
68     libjio.so libjio.a \
69     %i/lib
70    
71     install -m 644 \
72     INSTALL README UPGRADING \
73     %i/doc/libjio-%{v}
74    
75     strip %i/bin/* >/dev/null 2>&1 || true
76