ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mod_perl2.spec
Revision: 1.1
Committed: Tue Feb 5 18:26:23 2008 UTC (17 years, 2 months ago) by egeland
Branch: MAIN
Log Message:
adding

File Contents

# User Rev Content
1 egeland 1.1 ### RPM external mod_perl2 2.0.3
2     ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3    
4     # See http://perl.apache.org/docs/2.0/user/install/install.html
5    
6     Source0: http://perl.apache.org/dist/mod_perl-%realversion.tar.gz
7    
8     # Only require apache2 since perl is seeded from the system.
9     Requires: apache2
10    
11     # Doesn't actually provide these, but supposedly not needed for
12     # non-developers of mod_perl
13     Provides: perl(Apache2::FunctionTable)
14     Provides: perl(Apache2::StructureTable)
15     Provides: perl(Apache::TestConfigParse)
16     Provides: perl(Apache::TestConfigPerl)
17     Provides: perl(BSD::Resource)
18     Provides: perl(Data::Flow)
19     Provides: perl(Module::Build)
20    
21    
22     %prep
23     %setup -n mod_perl-%realversion
24    
25     %build
26     perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion MP_APXS=$APACHE2_ROOT/bin/apxs MP_AP_DESTDIR=%i
27     make
28    
29     %install
30     make install
31    
32     # By default mod_perl.so and include/ directory is moved to the
33     # $APACHE2_ROOT/modules and $APACHE2_ROOT/include, respectively, which
34     # is bad for us handling multiple versions in a rpm. With
35     # MP_AP_DESTDIR=%i this changes to %i/$APACHE2_ROOT, which will be a
36     # long directory path hardcoded at build time. Therefore, we have to
37     # move these resources back to a sane location and clean up.
38     mv %i/$APACHE2_ROOT/* %i
39     rm -r %i/$(echo $APACHE2_ROOT | sed 's|^/||' | cut -d/ -f1)