1 |
egeland |
1.9 |
### RPM external mod_python 3.2.10
|
2 |
|
|
# See http://www.modpython.org/live/current/doc-html/installation.html
|
3 |
steen |
1.4 |
|
4 |
egeland |
1.9 |
Requires: apache2 python
|
5 |
steen |
1.4 |
|
6 |
egeland |
1.9 |
Source0: http://apache.mirror.testserver.li/httpd/modpython/mod_python-%realversion.tgz
|
7 |
steen |
1.4 |
|
8 |
egeland |
1.10 |
%prep
|
9 |
egeland |
1.9 |
%setup -n mod_python-%realversion
|
10 |
|
|
|
11 |
|
|
./configure --with-python=$PYTHON_ROOT/bin/python --with-apxs=$APACHE2_ROOT/bin/apxs --with-max-locks=32
|
12 |
steen |
1.4 |
|
13 |
eulisse |
1.1 |
%build
|
14 |
egeland |
1.10 |
make
|
15 |
|
|
|
16 |
steen |
1.2 |
%install
|
17 |
egeland |
1.10 |
make install
|
18 |
|
|
|
19 |
|
|
mkdir -p %i/conf
|
20 |
|
|
cat << \EOF > %i/conf/mod_python.conf
|
21 |
eulisse |
1.11 |
LoadModule python_module %i/modules/mod_python.so
|
22 |
egeland |
1.10 |
# Additional configuration bits go here.
|
23 |
|
|
EOF
|
24 |
|
|
|
25 |
|
|
# By default mod_python.so and is moved to the
|
26 |
|
|
# $APACHE2_ROOT/modules directory, which
|
27 |
|
|
# is bad for us handling multiple versions in a rpm.
|
28 |
|
|
mkdir -p %i/modules
|
29 |
|
|
mv $APACHE2_ROOT/modules/mod_python.so %i/modules
|
30 |
|
|
|
31 |
egeland |
1.12 |
# Generates the dependencies-setup.{sh,csh} files so that
|
32 |
|
|
# sourcing init.{sh,csh} picks up also the environment of
|
33 |
|
|
# dependencies.
|
34 |
|
|
|
35 |
|
|
rm -rf %i/etc/profile.d
|
36 |
|
|
mkdir -p %i/etc/profile.d
|
37 |
|
|
echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh
|
38 |
|
|
echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh
|
39 |
|
|
echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
|
40 |
|
|
for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'`
|
41 |
|
|
do
|
42 |
|
|
case X$tool in
|
43 |
|
|
Xdistcc|Xccache )
|
44 |
|
|
;;
|
45 |
|
|
* )
|
46 |
|
|
toolcap=`echo $tool | tr a-z- A-Z_`
|
47 |
|
|
eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh
|
48 |
|
|
eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh
|
49 |
|
|
;;
|
50 |
|
|
esac
|
51 |
|
|
done
|
52 |
|
|
|
53 |
|
|
perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh
|
54 |
|
|
perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh
|
55 |
|
|
|
56 |
|
|
|
57 |
egeland |
1.10 |
%post
|
58 |
|
|
%{relocateConfig}conf/mod_python.conf
|
59 |
egeland |
1.12 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
60 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|