ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mod_python.spec
Revision: 1.2
Committed: Wed Apr 12 19:40:55 2006 UTC (19 years ago) by steen
Branch: MAIN
Changes since 1.1: +11 -1 lines
Log Message:
- Add command to place symbolic link to mod_python.so in the modules/
subdirectory
- Tested that module works with apache 2.0.55

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external mod_python 3.2.8
2     Source: http://apache.mirror.testserver.li/httpd/modpython/%{n}-%{v}.tgz
3 steen 1.2 ## INITENV +PATH PYTHONPATH %{i}/lib
4     ## INITENV CMD ln -sf $MOD_PYTHON_ROOT/lib/mod_python.so $APACHE_ROOT/modules
5 eulisse 1.1 Requires: python apache
6     %build
7     ./configure --prefix=%{i} \
8     --with-python=$PYTHON_ROOT/bin/python \
9     --with-apxs=$APACHE_ROOT/bin/apxs
10 steen 1.2 make
11    
12     %install
13     mkdir -p %i/lib
14     install -m 0644 src/mod_python.so %i/lib
15     cp -rp lib/python/mod_python %i/lib
16    
17     %files
18     %i