ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mod_python.spec
Revision: 1.4
Committed: Wed Apr 26 21:44:20 2006 UTC (19 years ago) by steen
Branch: MAIN
Changes since 1.3: +12 -9 lines
Log Message:
Use the setup.py script for building/installation.

Conrad Steenberg <conrad@hep.caltech.edu>
California Institute of Technology | http://conradsteenberg.info

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external mod_python 3.2.8
2 steen 1.4
3     %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
4     ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv}
5     ## INITENV CMD ln -sf $MOD_PYTHON_ROOT/lib/mod_python.so $APACHE_ROOT/modules
6    
7 eulisse 1.1 Source: http://apache.mirror.testserver.li/httpd/modpython/%{n}-%{v}.tgz
8     Requires: python apache
9 steen 1.4
10    
11 eulisse 1.1 %build
12     ./configure --prefix=%{i} \
13     --with-python=$PYTHON_ROOT/bin/python \
14     --with-apxs=$APACHE_ROOT/bin/apxs
15 steen 1.4
16     cd dist
17     python setup.py build
18 steen 1.2
19     %install
20 steen 1.4 cd dist
21     python setup.py install --prefix=%i