ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mod_python.spec
Revision: 1.7
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.6: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external mod_python 3.2.8
2 ratnik 1.7 Requires: gcc-wrapper
3 steen 1.4
4     %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
5     ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv}
6     ## INITENV CMD ln -sf $MOD_PYTHON_ROOT/lib/mod_python.so $APACHE_ROOT/modules
7    
8 steen 1.6 Source: http://apache.osuosl.org/httpd/modpython/%{n}-%{v}.tgz
9 eulisse 1.1 Requires: python apache
10 steen 1.4
11    
12 eulisse 1.1 %build
13 ratnik 1.7 ## IMPORT gcc-wrapper
14 eulisse 1.1 ./configure --prefix=%{i} \
15     --with-python=$PYTHON_ROOT/bin/python \
16     --with-apxs=$APACHE_ROOT/bin/apxs
17 steen 1.4
18 steen 1.5 make
19    
20 steen 1.4 cd dist
21     python setup.py build
22 steen 1.2
23     %install
24 steen 1.5
25     mkdir -p %i/lib
26     cp src/mod_python.so %i/lib
27    
28 steen 1.4 cd dist
29     python setup.py install --prefix=%i
30 steen 1.5
31     mv %{i}/lib/python%{pythonv}/site-packages/mod_python \
32     %{i}/lib/python%{pythonv}
33    
34     rm -rf %{i}/lib/python%{pythonv}/site-packages
35