Revision: | 1.6 |
Committed: | Thu Aug 24 22:37:02 2006 UTC (18 years, 8 months ago) by steen |
Branch: | MAIN |
CVS Tags: | forPHEDEX303, forPHEDEX302, forPHEDEX301, forPHEDEX300, forPHEDEX300pre14, forPHEDEX300pre13, forPHEDEX300pre12, forPHEDEX300pre11, forPHEDEX300pre7, forPHEDEX300pre6, forPHEDEX263, forPHEDEX262_cmsbuild2, forPHEDEX262_cmsbuild, forPHEDEX262, forPHEDEX261-slc3, forPHEDEX261, forPHEDEX260-1, forPHEDEX260, ge20071212-phedex, forPHEDEX2542, forPHEDEX2541, forPHEDEX2540, forPHEDEX2536, forPHEDEX2535, forPHEDEX2534, forPHEDEX2533, forPHEDEX2532, forPHEDEX2531, forPHEDEX253, forPHEDEX252, forPHEDEX251-micro-pre1, forPHEDEX251, forPHEDEX250, forPHEDEX242, forPHEDEX241, pe060927, for084, for137a_pre083_take2, for137a_pre083, ge20060825 |
Changes since 1.5: | +1 -1 lines |
Log Message: | Change to more sane mirror site. |
# | Content |
---|---|
1 | ### RPM external mod_python 3.2.8 |
2 | |
3 | %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2) |
4 | ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv} |
5 | ## INITENV CMD ln -sf $MOD_PYTHON_ROOT/lib/mod_python.so $APACHE_ROOT/modules |
6 | |
7 | Source: http://apache.osuosl.org/httpd/modpython/%{n}-%{v}.tgz |
8 | Requires: python apache |
9 | |
10 | |
11 | %build |
12 | ./configure --prefix=%{i} \ |
13 | --with-python=$PYTHON_ROOT/bin/python \ |
14 | --with-apxs=$APACHE_ROOT/bin/apxs |
15 | |
16 | make |
17 | |
18 | cd dist |
19 | python setup.py build |
20 | |
21 | %install |
22 | |
23 | mkdir -p %i/lib |
24 | cp src/mod_python.so %i/lib |
25 | |
26 | cd dist |
27 | python setup.py install --prefix=%i |
28 | |
29 | mv %{i}/lib/python%{pythonv}/site-packages/mod_python \ |
30 | %{i}/lib/python%{pythonv} |
31 | |
32 | rm -rf %{i}/lib/python%{pythonv}/site-packages |
33 |