ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mongo.spec
Revision: 1.28
Committed: Thu Mar 17 16:12:49 2011 UTC (14 years, 1 month ago) by diego
Branch: MAIN
CVS Tags: builder_2011-06-08_17-25-21_workqueue, builder_2011-06-04_17-45-11_dbs3, builder_2011-06-04_17-44-57_dbs3-client, builder_2011-05-19_15-09-56_wmagent, builder_2011-05-13_17-08-55_wmagent, builder_2011-05-11_13-24-46_dbs3-client, builder_2011-05-09_14-05-53_dqmgui, builder_2011-05-05_16-10-12_py2-sqlobject, builder_2011-05-05_13-16-07_dqmgui, builder_2011-05-02_19-33-26_cmsweb, builder_2011-05-02_18-58-25_cmsweb, HG1105c, builder_2011-04-15_14-49-10_wmagent, builder_2011-04-11_19-04-03_workqueue, builder_2011-04-08_17-08-57_cmsweb, HG1104e, builder_2011-04-08_12-05-32_calendar-shift, builder_2011-04-08_11-26-43_wmagent, ge20110407-igprof-book, builder_2011-04-07_19-51-01_calendar-shift, builder_2011-04-07_17-11-58_calendar-shift, builder_2011-04-07_16-23-25_calendar-shift, builder_2011-04-07_15-45-05_calendar-shift, TW20110407a, HG1104d, TW20110331c, TW20110331b, TW20110331a, TW20110330a, builder_2011-03-29_10-01-40_cmsweb, HG1104c, TW20110328a, builder_2011-03-25_15-38-34_cmsweb, builder_2011-03-25_12-48-58_cmsweb, builder_2011-03-24_17-23-46_reqmgr, builder_2011-03-23_16-16-18_cmsweb, builder_2011-03-23_16-04-32_cmsweb, builder_2011-03-23_11-32-11_cmsweb, builder_2011-03-23_10-48-54_cmsweb, HG1104b, builder_2011-03-23_09-32-23_cmsweb, TW20110322e, TW20110322d, TW20110322c, builder_2011-03-21_16-11-33_calendar-shift, builder_2011-03-21_16-08-10_calendar-shift, builder_2011-03-21_15-53-32_calendar-shift, builder_2011-03-18_17-21-58_cmsweb, HG1104a
Changes since 1.27: +8 -1 lines
Log Message:
fix to work with boost 1.46

File Contents

# User Rev Content
1 lat 1.26 ### RPM external mongo 1.6.5
2 diego 1.23
3     Source: http://downloads.mongodb.org/src/mongodb-src-r%{realversion}.tar.gz
4 lat 1.24 Requires: boost scons pcre spidermonkey rotatelogs
5 valya 1.1
6 valya 1.2 Provides: libpcap.so.0.8.3
7 valya 1.6 Provides: libpcap.so.0.8.3()(64bit)
8 valya 1.1
9     %prep
10 valya 1.7 %setup -n mongodb-src-r%{realversion}
11 valya 1.1
12 lat 1.27 # scons apparently removes $PATH and $LD_LIBRARY_PATH when invoking
13     # compiler commands, so force the environment back -- gcc needs it.
14     # this isn't actually quite enough as scons also forces -L/lib64
15     # type options straight into command line, with -lstdc++, etc., so
16     # linking is also likely somewhat broken.
17     cat > scons-sucks-wrapper <<-EOF
18     #!/bin/sh
19     . $GCC_ROOT/etc/profile.d/init.sh
20 diego 1.28
21     # Boost 1.46.0 has a bug on boost filesystem3, so we set to use filesystem2 instead.
22     # See http://www.freeorion.org/forum/viewtopic.php?f=24&t=5180
23     #
24     # We also get rid of deprecated bits that lead to compile warnings. See
25     # http://stackoverflow.com/questions/1814548/boostsystem-category-defined-but-not-used
26     exec c++ -DBOOST_SYSTEM_NO_DEPRECATED -DBOOST_FILESYSTEM_VERSION=2 \${1+"\$@"}
27 lat 1.27 EOF
28     chmod 755 scons-sucks-wrapper
29    
30 valya 1.1 %build
31 lat 1.27 scons %makeprocesses --64 --cxx=$PWD/scons-sucks-wrapper --extrapathdyn=$PCRE_ROOT,$BOOST_ROOT,$SPIDERMONKEY_ROOT all
32 valya 1.1
33 diego 1.28
34 valya 1.1 %install
35 lat 1.27 scons %makeprocesses --64 --cxx=$PWD/scons-sucks-wrapper --extrapathdyn=$PCRE_ROOT,$BOOST_ROOT,$SPIDERMONKEY_ROOT --prefix=%i install
36 valya 1.14
37 diego 1.22 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
38 valya 1.15 mkdir -p %i/etc/profile.d
39 diego 1.22 : > %i/etc/profile.d/dependencies-setup.sh
40     : > %i/etc/profile.d/dependencies-setup.csh
41     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
42     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
43     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
44     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
45     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
46     fi
47 valya 1.15 done
48    
49 valya 1.1 %post
50 diego 1.22 %{relocateConfig}etc/profile.d/dependencies-setup.*sh