ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.12
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
CVS Tags: pe20070428a-ports, pe20070423b-ports, pe20070423a-ports
Changes since 1.11: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM external mysql 5.0.18
2 ratnik 1.12 Requires: gcc-wrapper
3 eulisse 1.5 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/mysql
4    
5 eulisse 1.3 #Different download locations according to the version.
6    
7     %if "%(echo %v | cut -d. -f1)" == "4"
8     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%v.tar.gz
9     %else
10     %define source http://mysql.belnet.be/Downloads/MySQL-5.0/mysql-%v.tar.gz
11     %endif
12    
13     Source: %source
14 eulisse 1.6 # Let's fake the fact that we have perl (DBI) so that rpm does not complain.
15     Provides: perl(DBI)
16 argiro 1.1
17     %prep
18     %setup -n %n-%v
19     %ifos darwin
20     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
21     # so remove it. (FIXME: check if this is solved in a newer version.)
22     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
23     %endif
24    
25     %build
26 ratnik 1.12 ## IMPORT gcc-wrapper
27 argiro 1.1 CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
28     ./configure --prefix=%i --with-extra-charsets=complex \
29     --enable-thread-safe-client --enable-local-infile
30 eulisse 1.2 make %makeprocesses
31 eulisse 1.8 %install
32     make install
33 eulisse 1.11 perl -p -i -e "s|^#!.*perl(.*)|#!/usr/bin/env perl$1|" $(grep -r -e "^#!.*perl.*" %i | cut -d: -f1)
34 eulisse 1.4 %post
35     %{relocateConfig}bin/msql2mysql
36     %{relocateConfig}bin/mysqlaccess
37     %{relocateConfig}bin/mysqlbug
38     %{relocateConfig}bin/mysql_config
39     %{relocateConfig}bin/mysqld_multi
40     %{relocateConfig}bin/mysqld_safe
41     %{relocateConfig}bin/mysql_fix_privilege_tables
42     %{relocateConfig}bin/mysql_install_db
43    
44